Chrysler 300C & SRT8 Forums banner

61 - 73 of 73 Posts

·
Registered
Joined
·
43 Posts
Guys,

I have the the 9 speaker system and i want to replace them but still use the factory amp, can anyone tell me if the output is 2 ohms or 4 ohms as i haven't got a scooby when it comes to this and that's what i keep getting asked when i look at speakers? :wtf:

Thanks
 

·
Registered
Joined
·
749 Posts
I was told it’s a 2-ohm system.
 

·
Registered
Joined
·
34 Posts
Pretty sure it's 2 ohm for you as well.

Give them a test with your multimeter. Just select resistance on meter and touch the leads to your speaker terminals.
 

·
Registered
Joined
·
34 Posts
Update

Put the used Beats amp in last night. I'd upgraded to Infinity on the front and rear speakers. Shocking difference. The bass in the door actually sounds amazing now -- and those are original. Car is filled with music now. So my old factory amp was fried for sure. For $100 this is a must. Now I will admit the cheap Blaupunkt amp I hooked up to rear speakers previously was a little more crisp. But the Beats amp driving all six speakers now sounds better overall. So I'll stay with it -- until I get antsy haaa.

I've attached 3 pics. 1 of the plugs on amp, 1 of the little black gizmo that you need to remove to get to amp bolts, and 1 of the metal plate that the amp bolts on to. Black gizmo was the worst for me, 2 philips head screws that you just need to feel, can't see them. And wedging the new amp in is a little tricky but it fits fine.

Thx for the help guys!
 

Attachments

·
Registered
Joined
·
749 Posts
Just in case it helps anyone, the "black gizmo" as pictured is the handsfree/Bluetooth module, which may be a good thing to know since they are prone to failing. I took mine out when I upgraded the amp since it was shot, and have a replacement one on the way. Not looking forward to getting back in there but definitely miss my Bluetooth lol.
 
  • Like
Reactions: TheKrell

·
Registered
Joined
·
34 Posts
So weird it won't work. My part # matches but ends in AN. Do the bass speakers in the doors work? Did the dash speakers work with the original amp ? The wires on those dash speakers are stretched pretty tight, not much slack. Are you positive they are connected and didn't pull loose.
 

·
Registered
Joined
·
14 Posts
I wonder if the AN makes the difference? Do you have a 2015? I plugged the 2 amps in and only the rear speakers work. the door speakers and dash speakers dont work. I plug the alpine 276 watt amp back and everything works.
 

·
Registered
Joined
·
749 Posts
Well after trying 2 05064982AM amps I get no sound out of the front speakers. Starting to think these dont work with the 2015 models. Anyone know the beats amp part# for the 2015 300c?
From my earlier post: 68267301AB. This was the part # for my Beats amp from a 2016.
 

·
Registered
Joined
·
34 Posts
I have a 2012 300 C. Zach must right, changed the part #. The site I bought on eBay had part #'s and the years of vehicle they would fit. So Look around on eBay you may get lucky. It took me an hour of clicking around to find mine.
 

·
Registered
Joined
·
1 Posts
I can't comment on the Kicker amp but I just bought the Beats amp for under $60 shipped on eBay, part number 68267301AB. It just came in yesterday so I have not gotten a chance to install yet, but this part number says for 2015-2017. Mine is a 13, but it should work fine, the Beats or Harman/Kardon system is literally THE only option my Varvatos did not get when built so that has got to change ASAP lol.

So yes, I would get the Beats amp because it is a known plug and play upgrade, it has literally twice the power whereas Kicker gives you only 92w more, and they can be found pretty cheap since they are available used. Search for 5064982 on eBay and I think they start at $60.

I also have not heard of anyone installing the Kicker amp in a 2nd gen so it may only fit the first gens.
Spent two weeks looking for a way to upgrade the system without making changes to the factory setup. THANK YOU!!
 

·
Registered
Joined
·
1 Posts
Update: this thread gave me the urge to install the Beats amp I ordered and it is DONE. Even though it said for 15-17 it fits and works perfectly fine in my 13.

I forgot how nice the 552-watt amp is. :D Granted, my 200C had the 506-watt Alpine system but I had just gotten used to the 276-watt system in this one now. I've upgraded the dash speakers already so now to do the 6x9s and hopefully add a trunk sub.
I did this as well now I have a beeping coming from the speakers for a while then it seems to lock onto the music source any ideas how to fix this?
 

·
Registered
Joined
·
2 Posts
Hey guys, just purchased a replacement BEATS amp for my 2015 300c (part # 68267301AB). Not getting any sound from the front 3.5 dash speakers...any idea how to fix this? Sounds muffled without the highs coming thru the dash. Should I disconnect the battery for a while and connect and try again? I read on a thread this should be plug and play...Help!
 
61 - 73 of 73 Posts
Top