Chrysler 300C & SRT8 Forums banner

21 - 25 of 25 Posts

·
Registered
Joined
·
1,413 Posts
Details of your car and mileage would help plus codes please (Keydance - link if you don't have a reader) or go to an Autozone and get them to read

As above possible tone ring issue - Link
 

·
Registered
Joined
·
5 Posts
Details of your car and mileage would help plus codes please (Keydance - link if you don't have a reader) or go to an Autozone and get them to read

As above possible tone ring issue - Link
Scanner is saying lost communication with transmission control module. Car only has 98.000 Miles not even broke 100k yet. All original. To see this 07 you would not believe the great condition it's in. Very particular about my car and maintenance so not being able to correct and fix can drive someone bat shit crazy
 

·
Registered
Joined
·
5 Posts
Scanner is saying lost communication with transmission control module. Car only has 98.000 Miles not even broke 100k yet. All original. To see this 07 you would not believe the great condition it's in. Very particular about my car and maintenance so not being able to correct and fix can drive someone bat shit crazy
Car will not go over 25 mph running at 3200 rpm so to drive anywhere is not going to happen. When i can not get around the block safely or more possible damage
 

·
Registered
Joined
·
261 Posts
Did you check the relays in the fuse box in the boot??
I had the same issue and only the Fiat/Chrysler dealer managed to find the fault. Cost of the part £20.00!
 
21 - 25 of 25 Posts
Top