Chrysler 300C & SRT8 Forums banner

81 - 100 of 136 Posts

·
Registered
Joined
·
2 Posts
Hi , im interested in this for my 2007 300c srt8

Few questions if you dont mind me asking

So the headunit turns on the factory amp all good ?
and also can you connect an ipod to the headunit ?


thanks
 

·
Registered
Joined
·
458 Posts
Hi , im interested in this for my 2007 300c srt8

Few questions if you dont mind me asking

So the headunit turns on the factory amp all good ?
and also can you connect an ipod to the headunit ?


thanks
Yes, to both questions, as long as you have the USB ipod cable.
There are two usb ports that you can plug in to.
 

·
Registered
Joined
·
177 Posts
about to pull the pin on one of these units as linked to on the 1st page, unless there's something better now?
looks like they might be a big sale on their site in a few days, unless the website has not been updated and i missed out....

how's every ones unit holding up, no problems?

what about front/rear cameras, what have you used?
 

·
Registered
Joined
·
458 Posts
about to pull the pin on one of these units as linked to on the 1st page, unless there's something better now?
looks like they might be a big sale on their site in a few days, unless the website has not been updated and i missed out....

how's every ones unit holding up, no problems?

what about front/rear cameras, what have you used?
Mine has been holding up great so far.
Absolutely no issues.

The site does get updated a lot, so wait for the sale.
 

·
Registered
Joined
·
458 Posts
I only installed a rear camera, since I had one laying around from a previous android head unit that I had in another car.
That cam worked fine and has night vision, but there is nothing printed on it that says who made it.
 

·
Registered
Joined
·
177 Posts
just bought one of these units,
470$au, aliexpress have a 4 day sale on, so all up 520$au by the time taxes were added,
seller emailed asking for a dash photo within 30min, sent him 1 and he replied back with in 10min, impressed so far.
mines a wagon, so will have to cut an extra hole for the rear wiper switches.

now the delivery wait begins ....
 

·
Registered
Joined
·
63 Posts
just bought one of these units,
470$au, aliexpress have a 4 day sale on, so all up 520$au by the time taxes were added,
seller emailed asking for a dash photo within 30min, sent him 1 and he replied back with in 10min, impressed so far.
mines a wagon, so will have to cut an extra hole for the rear wiper switches.

now the delivery wait begins ....
Thanks for the tip! Price was 300 Euro and now it is back in 440 €.

I bought it also, with TDA7850 Amplifier Chip. I don't know is that better or not and do they solder that chip in place or not.

I have been waiting and waiting... Days feel like they were weeks.
 

·
Registered
Joined
·
458 Posts
I think it took about two weeks for me to get mine when I ordered it.
 

·
Registered
Joined
·
177 Posts
still waiting for mine, hasn't even left China yet according to the tracker....

installation has me worried tho, they asked about the large plug, but not the smaller one in back of original radio...
looking at the photos of the supplied cables i see where the large plug goes into the adapter leads, but not sure on the other...

will just have to wait an see!
 

·
Registered
Joined
·
458 Posts
It's really simple.
No two plugs are the same, so you really have to work at it to screw it up.
Don't forget the antenna adaptor that comes with it.

Oh, and don't forget to sacrifice a goat, and reconnect the battery. :p
 

·
Registered
Joined
·
177 Posts
yippie! radio turned up today. looks nice.

bit disappointing that there's no instruction manual / wiring diagram supplied.

quick look at the wiring in the car manual (pg 8W-80-124) and trying to cross reference them to the supplied plug adapter,
looks like the only wires that go to the Boston amp are the green (Rear L) and purple (Rear R) on the bottom of the plug.
the grey and white wires don't connect to any pins in the original plug.
i guess that's why the fader doesn't work.

do the wires, brown/black stripe "key 1", orange/black stripe "key 2", green/white stripe "dvr-ir" connect to anything?

now just have to cut the fascia out for the top switch to suit a wagon.

hope to try and fit in next few days.
 

Attachments

·
Registered
Joined
·
458 Posts
You don't have to worry about the stray unconnected wires.
 

·
Registered
Joined
·
177 Posts
ok, i have the radio off the fascia for when i cut out the top of the fascia to suit the wagon wiper switch.
pulled apart the aircon/heater controls and replaced the burnt out globes, not much brighter, but will do for now.

i sat the unit out of the fascia in the opening and plugged it in, up popped the chrysler logo, then the andriod logo.
so far i haven't needed to disconnect the battery, the boston amp seems to have picked it up.
will disconnect/reset when i install the reversing camera over the weekend.

sitting in my carport i connected to the home wifi, tho i get a lower signal strength when radio is pushed further into the dash,
wondering if a larger wifi ariel will help?

screen looks good, easy to navigate thru the pages, installed a couple of apps like home rollerdoor control, calander etc.

the EVIC shows the radio stations on FM, but the AM stations still say FM and the freq has an extra decimal point in it?

when i open the car door, it shows up on the radio screen, but it's the opposite side door that shows....

will post up some photos over the weekend.
 

·
Registered
Joined
·
458 Posts
Yeah, the signal strength is not the greatest on the wifi, but that can be improved.

First thing you have to pay attention to is the antenna and connector.
The antennas that come with the head unit has the center pin making it a mail connector.
The one on the back if the head unit is a female connector.
I had a higher db wifi antenna handy that had the center pin so I just used it for some increase in performance.
If you find a piece of solid core wire, like coax that is the right diameter you can snip off a piece and make your own center connector.

But there is a way to get a lot more signal strength if you need it, but it will cost a few dollars.

Buy a 12volt wifi signal booster from amazon and hook it into a wifi antenna and your head unit, and it will give a much stronger signal.
This way you could set the antenna anywhere in or on the car that you wanted too.
 

·
Registered
Joined
·
458 Posts
And the issues with the radio sounds like it is set for the wrong region.
There is a setting in settings to change that.

The door, well since you are in Australia, you are just looking at it upside down.

Again, I think that is a setting also.
 

·
Registered
Joined
·
77 Posts
Funny I just saw this thread. I had my brother install a android (Hizpo) head unit and a sub and amp.










So far I love it, outside of a wifi hiccup that prompted me to do a factory reset resulting in losing the pre-loaded navigation, and the torque app. I was really hoping to use the torque app.
Customer support leaves some to be desired, but it's all out of china so the language barrier is pretty limiting as to what they can do.

I'm going to get a 4g dongle and a sim card so it'll have it's own internet so wont' miss the navigation and can stream audio/video if I want without having to hotspot it to my phone.

I'm already thinking I'll pull the hizpo out of the car and put it in my truck and get another one for the car, prolly pumpkin brand as a friend of mine has a couple of those and seems to get better customer support, and they are the same dang thing from what I can tell specs wise.
 
81 - 100 of 136 Posts
Top