Chrysler 300C & SRT8 Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
My cel had been on for about 3 weeks when I finally needed an oil change so I had the dealer check it out. Said it was the EGR valve so I had them replace it. The next day, the light was on again. So I take it to the dealer today and they check it out, say that there were some codes that needed to be cleared and it would be ok. Now it's back on AGAIN. This is really frustrating. Since I have already paid for the light to go away (EGR), I'm going to keep taking it back til they get it right. What else could it be ???
 

·
Registered
Joined
·
668 Posts
My cel had been on for about 3 weeks when I finally needed an oil change so I had the dealer check it out. Said it was the EGR valve so I had them replace it. The next day, the light was on again. So I take it to the dealer today and they check it out, say that there were some codes that needed to be cleared and it would be ok. Now it's back on AGAIN. This is really frustrating. Since I have already paid for the light to go away (EGR), I'm going to keep taking it back til they get it right. What else could it be ???
You might want to post the error code ??? switch your key to ON then OFF three times at least and the error code would appear in your EVIC ... post the error number, it could help us finding the problem source :biggrin:
 

·
Administrator
Joined
·
23,436 Posts
Yes, and if you have any mods.

Bernie
 

·
Registered
Joined
·
116 Posts
Discussion Starter #4
Did the on/off thing. The code flashed then went away before I could write it down. Started with a P. Couldn't get it back up. No mods.
 

·
Premium Member
Joined
·
4,708 Posts
Most of the codes start with a "P".
Next time (and THERE WILL BE A NEXT TIME!) the CEL comes on you'll know where to look. Be prepared to write it down as it sometimes is not easy to keep the order of the numbers straight in your head and we could be off on a wild goose chase with a couple of transposed digits.

PS - Check the receipt for the EGR replacement. There ought to be an indication of what the original code was. We'll see if it had anything to do with the EGR!
 

·
Registered
Joined
·
116 Posts
Discussion Starter #6
This is what is reads on the work order: STAR/SCAN CODES P0571 P0138 BRAKE SWITCH 1 PERFORMANCE, 02 SENSOR 1/2 CIRCUIT HIGH, BOTH STORED CODES SENSOR 1/2 CIRCUIT HIGH, BOTH STORED CODES.

It's going back in Monday so they can stare at it and scratch their heads some more :dead1:
 

·
Registered
Joined
·
668 Posts

·
Administrator
Joined
·
23,436 Posts

·
Premium Member
Joined
·
4,708 Posts
This is what is reads on the work order: STAR/SCAN CODES P0571 P0138 BRAKE SWITCH 1 PERFORMANCE, 02 SENSOR 1/2 CIRCUIT HIGH, BOTH STORED CODES SENSOR 1/2 CIRCUIT HIGH, BOTH STORED CODES.

It's going back in Monday so they can stare at it and scratch their heads some more :dead1:
And they replaced the EGR for those?

Personally, my C had the P0571 code practically daily for two months! The stealership replaced the brake switch TWICE!, and the code continued to come. Eventually, over a period of some 6 months or so, and sometimes with as many as (11) stored codes at one time, while along the way replacing the radio (yes, the radio!), and with their last effort requiring them to have the car for 8 days, they found a bent pin in an 80-pin connector somewhere. Fortunately for me, that was all under warranty. No codes since!
 

·
Premium Member
Joined
·
4,708 Posts
Has the CEL reappeared? If so, what's the code in the EVIC?
 

·
Registered
Joined
·
116 Posts
Discussion Starter #11
And they replaced the EGR for those?!
No, those codes were pulled after the EGR had been replaced. The CEL has been on since.
 
1 - 11 of 11 Posts
Top