Chrysler 300C & SRT8 Forums banner
61 - 75 of 75 Posts

·
Registered
Joined
·
644 Posts
Hi
OK folks whats become of the fuse 11,14 issue, do we all agree it does nothing for the CRD?
 

·
Premium Member
Joined
·
1,005 Posts
Just done this to my new car but with the led across pin 85 & 87 & the diode between pin 85 & 86 , it's working well
 

·
Premium Member
Joined
·
656 Posts
Kaiser Bill: Thanks for taking the time to post this.

PHASEONE: Thanks for figuring this out and agreeing to share it with the rest of us.

I just did this to my ride. Probably for different reasons than you intended except for the obvious resetting to zero the adaptives without having to manually pull fuse 11. My tuner has been challenged with getting my car to idle at below 1000 rpms for the longest time. Granted I haven't made it easy on him by constantly adding things like a blower, then a new fuel system etc. My solution to date has been to pull fuse 11 each morning before heading of to work. If I did nothing but drive to work and back it was just fine. However, if I had meetings that I had to go to during the day I would notice a steady degradation to the idle quality with each successive trip until the engine would want dip the rpms at idle and stall. In short I had a three meeting tune. This wasn't the end of the world because after three startups during the day I would pull fuse 11 again. As you can imaging every now and then I would forget and find myself restarting my car at an intersection. More of an annoyance than anything but over time it became kind of a water torture without me realizing it.

Then came along your post. At first I said "how hard is it to pull fuse 11"? But after reflecting on it for a while I decided to give it a try. Maybe out of boredom, maybe out of curiosity, maybe because it was there, but for whatever reason I am very glad I did this. It works like a champ and now I've set my idle back down to 850 and am loving life. I will probably drop it to 750 if things keep looking good.

So after great celebration and fan fair I must again thank you from the bottom of my heart. You "across the pond'rs" aren't so bad after all. :)

P.S. I got some sticky back Velcro and mounted the relay on the bottom of the fuse box so it is completely out of site unless you open the fuse box to access the wiring harnesses underneath.
 

·
Premium Member
Joined
·
1,005 Posts
Glad to here it worked out for you , I now have the relay hidden fron view with a red LED working off pin 87 to check all is ok
 

·
Premium Member
Joined
·
1,005 Posts
Just a quick update , it's still working with no problems
 

·
Premium Member
Joined
·
1,005 Posts
Just another quick update , it's still working with no problems
 

·
Premium Member
Joined
·
1,005 Posts
Still no problems just more fun ;-)
 

·
Premium Member
Joined
·
656 Posts
My Tuner figured out how to disable the self-learn idle so I don't need to pull fuse 11 anymore. I disabled this mod and put fuse 11 back in. Thanks again for the DIY, it worked flawlessly for 6 months. Well worth the effort for someone in my past predicament.
 

·
Premium Member
Joined
·
1,005 Posts
Glad to be of service
 

·
Premium Member
Joined
·
656 Posts
fuse 11? ..................... are you sure? ;)
Would the "20 amp fuse in cavity 11 within the front power distribution center" work better for you?
 

·
Registered
Joined
·
101 Posts
Sorry I'm new to this mod
Can someone clarify for me please what fuse to pull (07-crd) and what does it do?

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
247 Posts
I've done this exactly as described but my car won't fire! Has anyone else had this trouble? I used the pink/grey wire, tested it. I'm unsure what I'm doing wrong.
 
61 - 75 of 75 Posts
Top