Chrysler 300C & SRT8 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
463 Posts
Discussion Starter #1
Okay, so I'm still getting that rattling noise in the rear. I can't see it being my suspension because my KW V2's are only 2 months old but it's still a possibility. I checked everything under the car and in the car from loose stuff in the trunk, battery, fuse box, trunk latch, rear seats, exhaust, bumper valence and I can't figure out what the rattle is. It only happens when I hit bumps with the right rear. Here's a video for a better idea:



Hopefully you guys can get an idea from this that might help me out.
Thanks!

AC
 

·
Registered
Joined
·
160 Posts
oh man I have no idea what that noise can be it sure is loud? if your dealer cant find out what that is i suggest you bring it somewhere else.
 

·
Premium Member
Joined
·
2,859 Posts
Is the spare tightened down. I had something like that after i matted the trunk the plastic lock nut holding the tire down was loose. Also check the exhuast bolst in the back by the resonators they could be loose.
Good Luck let us know.
 

·
Registered
Joined
·
463 Posts
Discussion Starter #4
The exhaust is as tight as it is gonna get so that's not it. Also, I don't have a spare so that's not it either. Plus, I'm afraid to take it to a dealer with the KW's. What if it is that KW's that are bad or they say the problem was from the KW's? I'm scared of the dealer.
 

·
Premium Member
Joined
·
2,859 Posts
Sorry missed the SRT thing.
I have the KW on my C and havent had any problems like this. If your to affraid of the dealer then you need to take it to a shop you can trust. Ask around usally you can find someone in your area that has had a good experance with one. Did you check the spring boots on both ends of the spring maybe there not seated right.
 

·
Registered
Joined
·
463 Posts
Discussion Starter #6
Everything looks tight and seated correctly wit the suspension. It started making the noise about 4 weeks ago as a very slight clank and got worse as time went on.
 

·
Registered
Joined
·
648 Posts
Is the noise coming from one section or all 4?
 

·
Registered
Joined
·
463 Posts
Discussion Starter #10
No, not the lugnuts. Since then I changed the rims to winter ones and...blah blah blah.....

I pulled the right rear shock. It has no rebound. Guess my 2 month old KW was defective. I'll call them in the morning.
 

·
Registered
Joined
·
463 Posts
Discussion Starter #12
Don't know. I didn't even know that they had a high failure rate until I got 'em. Then all these other people with the same problem started coming outta the woodwork. I REALLY wish I would've gotten bags instead.....
 

·
Registered
Joined
·
1,323 Posts
just put your stock rear suspension back on....that will eliminate the KWs for sure

i drive around at 0 psi with my bags at the rear and have never heard that noise
 

·
Registered
Joined
·
463 Posts
Discussion Starter #16
I don't have the stock shocks. I sold them. I removed the rear shocks while on the phone with a tech. These shocks are not supposed to have rebound. Also, they do not have any leaks plus, there is no play in the rob itself. Bushings are fine, too.
 

·
Registered
Joined
·
3 Posts
Okay, so I'm still getting that rattling noise in the rear. I can't see it being my suspension because my KW V2's are only 2 months old but it's still a possibility. I checked everything under the car and in the car from loose stuff in the trunk, battery, fuse box, trunk latch, rear seats, exhaust, bumper valence and I can't figure out what the rattle is. It only happens when I hit bumps with the right rear. Here's a video for a better idea:



Hopefully you guys can get an idea from this that might help me out.
Thanks!

AC
Check the lower bolt on the shocks. If it looks like some threads have been crushed replaced it. It fixed my rattle. I had been hunting it for years. It was a 6$ set of 2 bolts the whole time. Spent hundreds of dollars on the wrong parts. M12 1.75 is the bolt size.
 
1 - 19 of 19 Posts
Top