Chrysler 300C & SRT8 Forums banner

1 - 20 of 55 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Has anyone else had backup camera issues? Mine hasn't been working for about 2 weeks now. Screen just goes black and displays check entire surroundings. Every now and then it shows the display briefly then goes black. Any help? 51l miles on a 2012 limited
 

·
Registered
Joined
·
778 Posts
I Dont know a whole lot about these cars yet. Sounds like a short somewhere? If it were me, before I'd take it somewhere that will probably charge a lot, I'd start with the trunk area and see if you can check out the wiring right there behind the light and or in the trunk area as best as you can.

Like my 06 300 I had, I finally had a day to take out the whole center console, which wasnt hard at all, and a learning experience. Which also showed me a lot about some other stuff.. But with a newer car like that, or like my 2013 300C, I would probably be more hesitant to actually take it apart haha.. dont want to mess something up.

Or as im sure someone else may already know, could there possibly be a way to reset the Infotainment system? maybe that might work?
 

·
Administrator
Joined
·
19,734 Posts
Sounds like a camera signal fault.

It could be at the connector to the camera or to the head unit (check the harness connections).

Another possibility is the camera itself is faulty.

Lastly, and hopefully this is not the case, the head unit display or internal camera function connections are bad.

I assume the display works normally on other functions?
 

·
Premium Member
Joined
·
457 Posts
You state 51 miles on a 2012 Limited. Where did you purchase the car? Is it still under warrantee? If it is, don't mess around and bring it to the dealer.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Sorry meant 51k miles! I wish it only had 51 miles.
The head unit works perfectly aside from when it's in reverse. I have to assume it's something with the camera because the screen even displays check all surroundings but the rest of the screen is black. Guess I'll have to start ripping her apart.
 

·
Registered
Joined
·
169 Posts
As MADDOG stated, I would first check the video connection from the camera to your head unit. I installed a front camera, and when I first tested it, my display was the same as you described. It was simply the video connection.
 

·
Registered
Joined
·
539 Posts
One word: Extended Lifetime Warranty. OK, so I was never great in math.

Otherwise, I'd never heard of a problem like yours happening (others w/an intermittent working camera). Certainly post back regarding the particulars of how you had it corrected.
 

·
Registered
Joined
·
1 Posts
backup camera failed.

My 300 is at 45k miles. I disconnected the negative battery cable and pulled/reset the fuse before taking to the local garage. It was the camera. $200 for camera and $200 for labor.
 

·
Registered
Joined
·
668 Posts

·
Registered
Joined
·
460 Posts
$200 for labor!?!

Replacing the camera is LITERALLY a ten-minute job. I would have exploded if I got that bill!

The camera is $200, though...
 

·
Registered
Joined
·
460 Posts
Definitely sounds like the camera. I've heard of a couple instances where the camera wasn't sealed properly and allowed moisture to get inside, causing it to crap out after a couple of years.

You can purchase a new factory camera kit for about $200. The funny thing about the camera is that it costs $400 for just the camera/brake light, but only $200 for the entire kit that includes the wiring harness. Buy the kit, and just use the camera/brake light assembly.

Alternatively, you could buy a much cheaper camera that is integrated into your rear plate holder and run the wires to your head unit. It'll work just like the factory one.
 

·
Banned
Joined
·
122 Posts
Alternatively, you could buy a much cheaper camera that is integrated into your rear plate holder and run the wires to your head unit. It'll work just like the factory one.
Yep. You can get them on eBay for 30-40 bucks and they work better than the factory one...Night vision.....whooohoooo.
 

·
Premium Member
Joined
·
604 Posts
I noticed something about the rear cameras on my 300 and my wife's Laramie. Mine seems to have better clarity at night than the one on her truck? Am I just imagining this or is there actually a difference? They seem equal in daylight operation. I do like how on her system the guide lines actually turn with the steering to show the track of the vehicle. That is very useful.
 

·
Registered
Joined
·
1 Posts
have you checked uConnect downloads for free updates. I did today. Neither update fixed my back up camera but I think there is another one that I am looking for that mentions the back up camera. Mine behaved the same way but now is dead dead, no more intermittent times to see it turn on.
 

·
Registered
Joined
·
99 Posts
My camera just started getting a fuzzy picture last night. Tried cleaning the lens, but no different. Is it on it's way out? All other screen functions seem to work.
 

·
Registered
Joined
·
1 Posts
I have a 2013 300C with just over 51K and the camera went out this morning. Where is the connector to the camera or to the head unit (check the harness connections) located? The big screen display unit works perfectly well until you put it in reverse and then it says "Check Entire Surroundings." If this is the camera itself, it'll be the second major electrical issue in two months. The actuator on the right rear passenger door failed and the lock wouldn't go up and down. Please send answer to question as quickly as possible. Thank you.
 

·
Registered
Joined
·
539 Posts
I don't mean to show lack of concern for anybody else's real problem(s), but this post just reminds me that last week backing out of my garage I noticed my camera was WAY out of alignment, showing the tree line of my across-the-street neighbor. I admit I was P'O'd and UPSET!

Then I realized I'd left my trunk open... :boggled:
 

·
Registered
Joined
·
2 Posts
I was told that this is very common for 300's, as well as many GM vehicles. I recently purchased my 300c used and while still under warranty they fixed the back up camera. Would've been a $900 bill otherwise. $679.99 for the camera + labor.
 
1 - 20 of 55 Posts
Top