Chrysler 300C & SRT8 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
this isn’t my first 300, but it’s my first time dealing with this problem and can’t find much info. Hooked battery up backwards last weekend. Melted hot wire from starter to alternator, killed the alternator, and then lost all accessory function (radio climate control steering column blinkers front windows wipers sunroof etc) but car still ran and drove just fine aside from the not charging alternator. About 45 minutes later I got my steering column, climate control, windows, wipers, and lights back. But my radio, light switch, and sunroof still won’t work, and my fans will not kick on.

Things I’ve tried
similar fcm from the junkyard, different part number tho
Fixed the alternator situation
Replaced every single fuse in the car
Tried to swap front fuse ox’s but car wouldn’t start afterwards, had to put original back in

am I missing something?
 

·
Chrysler Customer Service Agent
Joined
·
1,160 Posts
Hello Jevenbell,

We're very sorry to hear of this happening with your vehicle! If you are unable to receive more feedback from here, we do recommend reaching out to your local FCA servicing dealer to have your concerns properly diagnosed. If you decide to schedule an appointment, please feel free to reach out to us via private message.

Alex
Chrysler Cares
 

·
Registered
Joined
·
2 Posts
this isn’t my first 300, but it’s my first time dealing with this problem and can’t find much info. Hooked battery up backwards last weekend. Melted hot wire from starter to alternator, killed the alternator, and then lost all accessory function (radio climate control steering column blinkers front windows wipers sunroof etc) but car still ran and drove just fine aside from the not charging alternator. About 45 minutes later I got my steering column, climate control, windows, wipers, and lights back. But my radio, light switch, and sunroof still won’t work, and my fans will not kick on.

Things I’ve tried
similar fcm from the junkyard, different part number tho
Fixed the alternator situation
Replaced every single fuse in the car
Tried to swap front fuse ox’s but car wouldn’t start afterwards, had to put original back in

am I missing something?
How did you fix the alternator problem ? I did the same thing. Got everything working but the alternator I had the fuesable link melt so I replaced it and still not charging
 
1 - 3 of 3 Posts
Top