Chrysler 300C & SRT8 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
I have an 05c. For some reason my brake light doesnt work. All my other lights on my tailights work, but when i step the brake pedal. I get nothing. all the bulbs are good. wires are securely connected. :pat: Lost my owners manual. Would appreciate any knowledge on this matter.
 

·
Registered
Joined
·
465 Posts
on my old mustang, there is this special gadget piece that was attached to the brake pedal high up under the console. when you pressed the brake, it sent a signal to the tail lamps to light on. come to find out, i broke the wire to it and i had to remove it and splice the wires back together. i dont know if most cars have something like that or not. also, check your fuses. that is always the first step in troubleshooting
 

·
Registered
Joined
·
435 Posts
yeah, we got one of those on ours, a tel-tell that your brake light switch might go out soon is that you'll be able to hear a "stretchy spring" noise when you press the brake. like when you pull the spring out, if you ever worked on a car with a carb you'll know the sound...

not hard to replace, look for the circuit to be open or if you need to replace the switch it should have a simple pug on it and the switch it self will usually screw into or clip onto the pedal assembly right along the brake pedal stand..
 

·
Registered
Joined
·
56 Posts
Discussion Starter #4
Brake Light Fuse Alright

THANKS FOR THE HELPFUL 411. BUT IT WAS SIMPLE FIX -- BAD FUSE:pat:
 
1 - 5 of 5 Posts
Top