Chrysler 300C & SRT8 Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2010 Chrysler 300c 5.7 with roughly 65k miles. I'm a service advisor at a shop in San Diego and keep my C as clean as possible. All maintenance has been performed, even preventative.

Anyhow, I get a slight buzz mostly in the pedal but can also produce a slight white noise. You can hear it upon hard take offs. I've checked all of the mounts, done trans service and checked for metal scrap to determine if the clutches are wearing..nothing. The mounts don't appear to be broken, nor does the u joint, but it really feels like a mount! Especially because it's only when I put the power down (doesn't matter if trac is off). The car obviously leans backwards upon hard acceleration and therefore puts more stress on rear components. Not only this, but I can hear it coming from behind me as I drive.

I'm not confusing this with the horrid mds shudder (I'm not even going to get in to that).

So...any ideas? I can't find a forum with these specific symptoms so I apologize if you can use this site better and there's an existing thread I couldn't place.


Also, what's with the exhaust manifolds on these cars?! I don't like ANY noise a car shouldn't make, and these weak manifolds make an unpleasant noise (mainly when cold, or in a tunnel/in mds). Looking to swap to aftermarket header exhaust manifold setup. Any downsides y'all have experienced? Sorry for being so long winded.

Thanks much

Patrick
 
1 - 1 of 1 Posts
Top