Chrysler 300C & SRT8 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
327 Posts
Discussion Starter #1
I had this problem all of a sudden . I'm driving A/C blasting and radio and its pretty hot down here down south. All of a sudden while driving all my instrument lights start going off and a/c stops like the car was freaking out and losing power or sumthing. It is was pretty intermitten and lasted for 3 sec and everything was fine after that. It happend to me a few months back also. What in the world could this be? All my years with cars I never experienced anything like that before. Help! Could the battery be out of juice?
 

·
Registered
Joined
·
683 Posts
what was your engine temp looking like? You could have the alternator going bad as well. Do you know how to check the battery voltage though the Easter Egg? Press and hold the compass and music buttons for about 10 seconds then scroll though til you see it.

Other than that I don't know. Might need to take it to the dealer.
 

·
Registered
Joined
·
566 Posts
This happened to my sisters Saturn last week and this weekend. It ended up being old corroded battery cables. We replaced them and it fixed the problem. Her car is a 96 though, yours seems too new to have that problem but you never know.

Maybe you were drawing too much power and your alternator couldn't handle it.
 

·
Registered
Joined
·
327 Posts
Discussion Starter #4
what was your engine temp looking like? You could have the alternator going bad as well. Do you know how to check the battery voltage though the Easter Egg? Press and hold the compass and music buttons for about 10 seconds then scroll though til you see it.

Other than that I don't know. Might need to take it to the dealer.
I just take it to the dealer. Hopefully its nothing major. It does seem to happen on really hot days when I'm blasting the A/C and radio. Thanks for the advise guys.
 
1 - 5 of 5 Posts
Top