Chrysler 300C & SRT8 Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
470 Posts
Discussion Starter #1
i have a 07 w/ a 2.7 motor. last week my wife was driving and she said it would'nt pass 45mph. i took it to the dealer and it was fine when they drove it. now it did it again yesterday, and when i took it in it was fine again. they said they cant do anything b/c it's not having a problem when there test driving it. she said it does'nt rev out or anything it just does not go pass 45 and the gas pedal feels stiff and would go down all the way. i cant really give any other info b/c i did not drive the car when the problem was occuring. any ideas on what could cause this problem would be very helpful. thanks.
 

·
Premium Member
Joined
·
6,091 Posts
Either an issue with the electronic throttle sensor on the gas pedal... or maybe something like a bottle or the carpet balling under the pedal when she drives... other than that, kind of hard to diagnose..
 

·
Registered
Joined
·
435 Posts
Here is something crazy, and don't laugh, cause it has happened to me...
First I have to ask if this has happened while you were driving?

If not, my second question is does your wife wear heels?

Um... (I'm biting the first one who sinkers at this,LOL)
I had an experience once with a slammed hard body classic Ford-F-1 I was driving. Not mine but still, i kept it most of the time...
anyway, I had a similar experience, would go past... about 40-45, pedal was stiff but the engine wouldn't rev up (or out) despite me laying the peddle all the way down (or so I thought)
As it turned out, I had some shoes with some pretty tall heels on and the heel part of my strappy accesory was getting caught under the peddle...
LOL.
Think I turned about 20 shades of red when we figured it out...
Just a thought...
 

·
Registered
Joined
·
470 Posts
Discussion Starter #5
Either an issue with the electronic throttle sensor on the gas pedal... or maybe something like a bottle or the carpet balling under the pedal when she drives... other than that, kind of hard to diagnose..
thats what im thinking the electronic trottle sensor, i checked the carpet there's nothing obstructing the gas pedal. would the sensor cause the pedal to be stiff?
 

·
Registered
Joined
·
470 Posts
Discussion Starter #6
Here is something crazy, and don't laugh, cause it has happened to me...
First I have to ask if this has happened while you were driving?

If not, my second question is does your wife wear heels?

Um... (I'm biting the first one who sinkers at this,LOL)
I had an experience once with a slammed hard body classic Ford-F-1 I was driving. Not mine but still, i kept it most of the time...
anyway, I had a similar experience, would go past... about 40-45, pedal was stiff but the engine wouldn't rev up (or out) despite me laying the peddle all the way down (or so I thought)
As it turned out, I had some shoes with some pretty tall heels on and the heel part of my strappy accesory was getting caught under the peddle...
LOL.
Think I turned about 20 shades of red when we figured it out...
Just a thought...
No it never happened when i drive. and she doesnt wear heels b/c she works in a medical office so she wears sneakers
 

·
Premium Member
Joined
·
6,091 Posts
Not sure as I haven't any experience with that yet, but maybe someone else here would.

Is it always stiff, or just when the car won't go past 45? I'd take it to the service dept and have them take a look at it.
 

·
Administrator
Joined
·
23,437 Posts
I don't know, but it sounds to me it may have gone into limp mode, which clears itself when restarting. The check your transmission comment may not be all that far off. As these cars are throttle by wire, unless there's an obstruction I can't see what could be doing that. There have been a few cases of the gas peddle breaking off though. Could also be partially broken which may cause the stiffness I guess??? I'm gonna search those out.

Bernie
 

·
Registered
Joined
·
1,108 Posts
The 2.7 used to be a problem engine, im not sure if it still is the same. Id do a little looking into what some of the past problems are that may have occured on other vehicles with the 2.7L and see if this problem occured for anyone else (intrepid, concorde, sebring etc look back to the late 90s till today.)
 

·
Registered
Joined
·
435 Posts
Hey, know what... maybe she accidentally knocked it into a lower gear, you know with the driver being able to manually control the tranny gears and all... don't see it affecting how the peddle feels but definitely would make a dif...
 

·
Administrator
Joined
·
23,437 Posts
Well, whether this has anything to do with the problem or not remains to be seen, but it seems the whole assembly is made from plastic. There are numerous breakages at Charger forums and lxforums.

Bernie
 

·
Registered
Joined
·
470 Posts
Discussion Starter #12
the thing is when i drive it it's normal. but she said it happed twice. the reason im not leaning to trans problem is b/c it doesnt rev out. the rpm remains the same but the car wouldnt go pass 45. the pedal is not stiff all the time. i never experience this b/c it never happened when im driving. it's just strange.
 

·
Registered
Joined
·
261 Posts
I think 45mph is the top speed for the 2.7L. :biggrin:
 

·
Registered
Joined
·
288 Posts
Did she accidently downshift the tranny? My wife did that once. Car was in first, and she did not realize what was happening, or how to recognize what the dash was telling her.

Just a thought.
 

·
Registered
Joined
·
470 Posts
Discussion Starter #15
Did she accidently downshift the tranny? My wife did that once. Car was in first, and she did not realize what was happening, or how to recognize what the dash was telling her.

Just a thought.
if she downshift the tranny the rpm would still rise right? she said the rpm stays around 2500, it's not reving out. but it never happened w/ me and i've been driving around all weekend.
 

·
Administrator
Joined
·
23,437 Posts
if she downshift the tranny the rpm would still rise right? she said the rpm stays around 2500, it's not reving out. but it never happened w/ me and i've been driving around all weekend.
Is your gas peddle still stiff? I still think it just went into limp mode though which clears itself on restarting.

Bernie
 

·
Registered
Joined
·
181 Posts
my car had a similiar problem shortly after i got it new with 2100 miles on it. i had to have it towed as it finally wouldn`t go past 40 at all. that it was in limbo mode. they first checked and pulled a code as p0758, and found that the tcm was at fault they replaced the tcm and still had the same code. so they called startech and was advised to remove valve body and check 2/3 shift valve for sticking in bore. they removed and checked valve and installed a new one. it cleared the code and test drove. all is fine now. not sure if that`s your problem but it may help.:biggrin:
 

·
Registered
Joined
·
353 Posts
You are so lucky. You have got what I want. A car that will only go up to 45mph when my wife drives it. Wow, what a money saver.
 

·
Registered
Joined
·
288 Posts
You are so lucky. You have got what I want. A car that will only go up to 45mph when my wife drives it. Wow, what a money saver.
Ditto, but I would rather have that feature for my teenage son. The piece of lead on his right leg/foot is MUCH larger than mine. :lick:
 

·
Registered
Joined
·
435 Posts
Ditto, but I would rather have that feature for my teenage son. The piece of lead on his right leg/foot is MUCH larger than mine. :lick:
Ugh, men...it's always about size isn't it, LOL.
 
1 - 20 of 23 Posts
Top