Chrysler 300C & SRT8 Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
188 Posts
Discussion Starter #1
I have installed a full exhaust system with the Kooks headers and high-flow cats and the magnaflow cat back exhaust and I have the GSM CAI and the Torque / Fan mod with the 180 degree T-stat. My check engine light came on yesterday afternoon and I guess I'll find out why when I take it to the dealer but I am wondering if anyone else who has done these mods has had this problem and if there is anyway to prevent it from happening once I get it cleared. I don't want to have to go to the dealer all the time to get it cleared nor do I want to drive around all the time with my CEL on. Thanks in advance for the help.

Jed
 

·
Registered
Joined
·
188 Posts
Discussion Starter #3
330toSRT8 said:
Pull fuse #11 for 15 seconds and it will reset the CEL. I've had one CEL so far and I suspect it had to do with my 170 thermostat.
I will do that - thanks for the tip. BTW, what is fuse #11 for?
 

·
Registered
Joined
·
188 Posts
Discussion Starter #5
330toSRT8 said:
Pull fuse #11 for 15 seconds and it will reset the CEL. I've had one CEL so far and I suspect it had to do with my 170 thermostat.
I pulled fuse #11 and the CEL didn't go out (what is MIL? I'm guessing it is a CEL in different terms). I'm going to try to found out what the code is with the "On-ACC" cycle x3. I'm open to any and all suggestions. Thanks.
 

·
Registered
Joined
·
188 Posts
Discussion Starter #6
JWunderli said:
I pulled fuse #11 and the CEL didn't go out (what is MIL? I'm guessing it is a CEL in different terms). I'm going to try to found out what the code is with the "On-ACC" cycle x3. I'm open to any and all suggestions. Thanks.
I just performed the cycle and the code is P0420. I'll p.m. Steve to find out what that is and let you all know.
 

·
Premium Member
Joined
·
4,541 Posts
JWunderli said:
I pulled fuse #11 and the CEL didn't go out (what is MIL? I'm guessing it is a CEL in different terms).

MIL is "malfunction Indicator Lamp" , so yeah, same thing different name.

If you know someone with the Superchips Flashpaq it also functions as a scan tool / code reader for ANY Chrysler vehicle (at least according to the liturature that came with mine). There's got to be somebody in the Las Vegas/Henderson area with a flashpaq you can use to check it out.
 

·
Registered
Joined
·
612 Posts
JWunderli said:
The code list says the catalyst system efficiency is below the threshhold - Bank 1. I wonder what causes that, though. Any ideas?
it's most likely a symptom of your high flow cats. your ecu will perform periodic readings from the o2 sensors just after the primary cats and when it does you'll continue to get that cel until someone can rewrite these ecu's for use with high flow or no cats.

it can easily be fixed with black electricians tape. ;)
 

·
Registered
Joined
·
188 Posts
Discussion Starter #12
chiromikey said:
it's most likely a symptom of your high flow cats. your ecu will perform periodic readings from the o2 sensors just after the primary cats and when it does you'll continue to get that cel until someone can rewrite these ecu's for use with high flow or no cats.

it can easily be fixed with black electricians tape. ;)
Great!! You tell me it's an easy fix with electrician's tape (I assume the plastic kind and not the cloth) and then you don't tell me how to do it?!? Man, that's like showing me the ice cream and not telling me I can have a bowl. Help a brother out and enlighten me. Thanks. BTW, when my business partner was shopping for a car and getting frustrated, I did a "Build Your Own" of an E55 AMG for him and he bought it about a month later. We have had lots of fun testing the limits of that car. Sweet ride you have chosen.

Thanks again.
 

·
Registered
Joined
·
612 Posts
JWunderli said:
Great!! You tell me it's an easy fix with electrician's tape (I assume the plastic kind and not the cloth) and then you don't tell me how to do it?!? Man, that's like showing me the ice cream and not telling me I can have a bowl. Help a brother out and enlighten me. Thanks. BTW, when my business partner was shopping for a car and getting frustrated, I did a "Build Your Own" of an E55 AMG for him and he bought it about a month later. We have had lots of fun testing the limits of that car. Sweet ride you have chosen.

Thanks again.
lol...sorry bad joke...i meant put some tape over the light until a real fix is available.:nutkick:
 

·
Registered
Joined
·
188 Posts
Discussion Starter #14
chiromikey said:
lol...sorry bad joke...i meant put some tape over the light until a real fix is available.:nutkick:
Aw man, you got me all excited for a REAL fix and all I get is this? For a minute I thought my team had won the championship until I realized it was only a dream and I have to wait til next year. Darn it. But seriously, I'm guessing there's no real problem other than it just doesn't like the less restrictive cats, correct? Your thoughts?...
 

·
Registered
Joined
·
370 Posts
Most likey your high flow cats aren't cleaning the air enough(burning the excess fuel) and your 02's are catching that. search online for some 02 sims, then the electrical tape suggestion will work. They require splicing the wires. What they do is send a false "all OK" signal to the computer allowing you to run what ever you want to. Even no cats if you were so inclined. Last time I checked I think they were like 80 bucks a piece or something maybe cheaper.

but to answer your question...no there really isn't a problem with your car. Its just modern technology (trying to adhere to the emmision laws set by our government) telling you YOUR car has a problem.
 

·
Registered
Joined
·
267 Posts
have the same problem with kooks and high flow cats. Have had 0420 and 0430 since install. Seems like theres no way around it, no one can confirm if the sims really work. I tried the washer fix, didnt do anything. Then I started getting 0133 and 0153 for a while. Went away on its own. Now I am getting P2098. This sucks. I feel like taking the headers off, didnt provide much of a gain and I hate looking at the stupid cel light on the dash.
 

·
Registered
Joined
·
370 Posts
Here ya go. Give this guy and e mail. He makes "ghetto sims". they are little adapters that the 02 plugs into and allows it to read cleaner air, by backing the sensor out of the pipe. I've been using one on my 04 spec V for over a year now. No check engine light. they are only 10 bucks shipped so it's worth checking it out. I ordered it and got it like 3 days later.

he is Graymulligan over at www.thevboard.com
his e mail is [email protected]
 

·
Registered
Joined
·
1 Posts
Howdy! figured I would drop in and do some 'splainin.

O2 sensors essentially compare "air samples", for lack of a better term. The air comes out of the motor, and the first 2 sensors (header area, before the cats) read "dirty air".

Then, the air goes through the cats, gets cleaned up, and is read by the second set of sensors as "cleaner than the other reading".

I machine a part that acts as a sort of spacer between the O2 bung on the exhaust and the sensor. It moves the second O2 sensors out of the direct flow of exhaust, and makes them read cleaner than they should. Nothing too sexy, just a mechanical solution to an annoying issue.

I've been selling them for a while over at a couple of the ser sites, and I've also machined a few sets for some folks with GM products, and a few suburus. I don't see any reason that it wouldn't work on the Chryslers as well, as they use the same system of reading clean/dirty air.

What I need is someone who's knowledgeable about their exhaust to drop me an email so that I can get some specs on the sensor used in your exhaust. I'll machine a couple, get em shipped out, and test fitted. Obviously the most important thing on my end is getting the specs right so that they're plug_and_play.
 

·
Registered
Joined
·
2,102 Posts
i see everyone talking about kooks headers....what about dynoMAXX...
do you think the same thing will happen?....i asked a few others
that have them and they said NO codes what so ever??...
iam just about to buy a set....but now i dont know...grrrrr
i couldnt live with the cel light always on either....
dammit man.....what to do...
 
1 - 20 of 24 Posts
Top