Chrysler 300C & SRT8 Forums banner

21 - 24 of 24 Posts

·
Registered
Joined
·
10 Posts
I had Kooks installed and the Cel lit up immediately. My mechanic called Kooks and was told that was pretty common as the sensors were too long and misread the exhaust. I had to go to a dealer to get it turned off as no one had a scanner that would read the new 300 srt. I bought O2 sims from GSM but they didn't work so my light is still on. By disconnecting the battery for 5 or 10 minutes the light will reset. After starting the enigine a couple of times it comes back on.
Popeye
Popeye
 

·
Registered
Joined
·
3 Posts
Im having the exact same problem

JWunderli said:
I have installed a full exhaust system with the Kooks headers and high-flow cats and the magnaflow cat back exhaust and I have the GSM CAI and the Torque / Fan mod with the 180 degree T-stat. My check engine light came on yesterday afternoon and I guess I'll find out why when I take it to the dealer but I am wondering if anyone else who has done these mods has had this problem and if there is anyway to prevent it from happening once I get it cleared. I don't want to have to go to the dealer all the time to get it cleared nor do I want to drive around all the time with my CEL on. Thanks in advance for the help.

Jed
Hi i just installed kooks long headers with hi flow cats and my engine light is on and my gas consumption indicator is very hi and the car doesn't seem to run better but worse any suggestions
 

·
Registered
Joined
·
2,102 Posts
fsn_srt8 said:
Hi i just installed kooks long headers with hi flow cats and my engine light is on and my gas consumption indicator is very hi and the car doesn't seem to run better but worse any suggestions
man i wonder if this is just a problem with kooks.....
i havent heard of any dynatech problems....
iam really going to have to find out before i buy...
 

·
Registered
Joined
·
267 Posts
I went and bought some exhaust seal paste from a local store, and it closed up my leak for now. The lean condition codes (P0133, P0153, P2098) went away. But I still have P0430. No P0420 though, just the P0430 cat efficiency code.
 
21 - 24 of 24 Posts
Top