Chrysler 300C & SRT8 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
I just got my stage 2 AFE air intake and just did the install, everything when smooth and easy. I very like the gain and the sound of this unit, but after 1/2 hour cruising the check engine light came on, anybody have any idea, I think my sensor for the air was not plug correctly but How do I reset the computer

All the info will be awesome

Thank you

Steve

I will be posting some picture later tonight
 

·
Premium Member
Joined
·
4,708 Posts
I just got my stage 2 AFE air intake and just did the install, everything when smooth and easy. I very like the gain and the sound of this unit, but after 1/2 hour cruising the check engine light came on, anybody have any idea, I think my sensor for the air was not plug correctly but How do I reset the computer

All the info will be awesome

Thank you

Steve

I will be posting some picture later tonight
Turn your key on/off/on/off/on (without starting the engine) and read/record the codes that will show in the EVIC where the mileage is displayed. Then report your findings here.

More than likely, after three or four normal run cycles the light will extinguish all by itself.
 

·
Registered
Joined
·
325 Posts
Check the air sensor, then remove fuse 11 for a while to rest the computer, if this didn’t work, disconnect the car battery for some time and everything and every thing should go back to normal. But make sure you follow the battery reconnection procedure.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #4
It said to check my gas cap so I did and everything seem to be tight. I remember when I was cruising I stop for gas so probably did not tight the cap enought. So now how do I reset the check engine light only by pulling out fuse 11
Thank you
 
1 - 5 of 5 Posts
Top