Chrysler 300C & SRT8 Forums banner

1 - 20 of 270 Posts

·
Registered
Joined
·
541 Posts
Discussion Starter #1
The purpose of this thread is to gather a list of all owners who have (currently, or in the past) the cloudy collant/cottage cheese issue:

http://www.300cforums.com/forums/srt8-general-discussion/28222-cloudy-coolant-any-thoughts-answers.html

The aim is to gather information to be presented either to DCX, or on the next SRT Engineering Team chat, or both.

To that end, if people can respond with the following information:

- Year and model (i.e. 2006 SRT-8, 2005 300C, etc...)
- Car build date (if you can find it, this will be rather helpful)
- When you first saw the problem
- Whether you still have the problem (and what was done to solve it, if applicable)
- Approximate milage

I/We will gather this information to be presented at the next SRT Engineering chat, or present it to DCX. What we're looking for is an explanation, and a resolution (if needed - it may be "normal" once we get an explanation!).

The idea is that all of us, with one voice, will be more powerful and to the point than many smaller voices.

Thank you all for contributing.

And, a special thanks to those who have already gone through the effort of raising and troubleshooting these issues, specifically (but not limitted to - sorry if I missed you) EricG, Ali"i 300C, NYC SRT8, and GEN XER.
 

·
Registered
Joined
·
2,505 Posts
GEN XER

- Year and model: 2006 SRT-8
- Car build date: Jan 2006
- When you first saw the problem: Jan 2007
- Whether you still have the problem: Yes, Tank Replaced and Flushed at <2K miles
Current mileage 5660 miles. Corrosion is back.
 

·
Registered
Joined
·
2,328 Posts
nyc_srt8

-Year and model: 2006 300c srt8
-Car build date: April 2006
-When you first saw the problem: Oct 2006
-Whether you still have the problem: Yes, current miles 16,900
 

·
Registered
Joined
·
826 Posts
1fastsedan

-Year and model: 2006 300c srt8
-Car build date: 5/5/06
-When you first saw the problem: Dec 2006, Approximately 6,000 miles
-Whether you still have the problem: Flushed with recovery tank replaced 12/06 at 6,000 miles, problem has returned but less severe at 11,000 miles
 

·
Registered
Joined
·
44 Posts
- Year and model 2006 300c SRT8
- Car build date Feb 06
- When you first saw the problem April 07
- Whether you still have the problem Yes going to take it in and try to have the coolant tank replaiced and system flushed.
- Approximate milage 9300
 

·
Registered
Joined
·
4 Posts
- Year and model: 2006 Charger SRT-8
- Car build date: 06/17/06
- When you first saw the problem: Feb, 2007
- Whether you still have the problem: Yes, not serviced or flushed
Approximate milage: 10,100
 

·
Registered
Joined
·
37 Posts
Dux
- Year and model: 2006 Chrysler 300 SRT-8
- Car build date: March or April 06
- When you first saw the problem: Jan, 2007 - System flushed and reservoir tank replaced at +/- 3100 miles
- Whether you still have the problem: Yes, no more white floaties, but cloudy and ammonia smell has returned -- taking it back soon
Approximate milage: 5400
 

·
Registered
Joined
·
1,032 Posts
- Year and model (i.e. 2006 SRT-8, 2005 300C, etc...)
2006 Chrysler 300 SRT-8
- Car build date (if you can find it, this will be rather helpful)
November 2005
- When you first saw the problem
The dealer's SRT tech actually noticed foam and ammonia smell on July 3rd,
2006.
Original thread where I reported:
http://www.300cforums.com/forums/srt8-general-discussion/21207-your-coolant-foaming.html?highlight=amonia
- Whether you still have the problem (and what was done to solve it, if applicable)
The foam is gone, but there is a white substance floating in the coolant as well as a thick buildup of the white substance at the bottom of the overflow tank.
- Approximate mileage
32,000 miles
 

·
Premium Member
Joined
·
4,068 Posts
-2006 300C SRT8
-March 06 build
-Noticed Nov-Dec 06
-Had it flushed with 2000 miles on the odo, seems to be clear since then but unsure about related effects and any potential damage done.
-Currently at 9000 miles

Eric
 

·
Registered
Joined
·
201 Posts
Member H2SRT8
- Year and model: 2006 SRT-8
- Car build date: July, 2006
- When you first saw the problem: April, 2007
- Whether you still have the problem: Yes, not diagnosed, serviced or flushed
Approximate milage: 2,800
 

·
Registered
Joined
·
1,532 Posts
Cloudy Coolant

DanRealtor 2006 300CSRT-8. Coolant was cloudy with noticeable deposits in the overflow tank. The dealer flushed and refilled it at 45,000 miles. The deposits are still in the overflow tank. The car has 57,000+ miles now. The car was built on 8/3/05.

My buddie Eddie (WagonDoc) also has the same issue on his 2006 Magnum SRT-8.
 

·
Banned
Joined
·
6,059 Posts
- Year and model 2006 CSRT
- Car build date March 2006 Purchased Oct 06
- When you first saw the problem Feb 2007
- Whether you still have the problem Yes, 2 delears stated it was normal and refused any work
- Approximate milage 4800 miles.
 

·
Registered
Joined
·
409 Posts
C4PC

- Year and model: 2006 SRT-8
- Car build date: Oct, 2005
- When you first saw the problem: March, 2007
- Whether you still have the problem: Yes, not diagnosed, serviced or flushed
Approximate mileage: 28,000km
 

·
Registered
Joined
·
626 Posts
2006 300c SRT8 - Year and model (i.e. 2006 SRT-8, 2005 300C, etc...)
March '06 - Car build date (if you can find it, this will be rather helpful)
15,000 - When you first saw the problem
Still exists, one dealer blew me off - Whether you still have the problem (and what was done to solve it, if applicable)
18,000 - Approximate milage

 

·
Registered
Joined
·
299 Posts
2006 MSRT
Build Aug 05
14,000
Noticed Aug 06 - smell and light residue in tank
No longer cloudy or "chunky" (not yet)- Drained and flushed by me, refilled w/ Peak Global AOAT type coolant
 

·
Registered
Joined
·
430 Posts
Shade
2006 SRT 8
Build date 04/2005
Saw this issue as soon as the thread was introduced. Replaced and flushed coolant at 13k. Now at 16k
Seems OK.
 

·
Registered
Joined
·
2,344 Posts
DaveW68

Car: 06 CSRT
Build date: 12-05, purchased new 3-07
First saw problem: 4-07, as soon as I was introduced to the issue. The anti-freeze has become lighter in color over the last couple of weeks and there is a definite cloudiness.
Do I still have the problem: Yes, not diagnosed, serviced, or flushed yet.
Current milage: Approx 1400
 
1 - 20 of 270 Posts
Top