Chrysler 300C & SRT8 Forums banner

21 - 40 of 67 Posts

·
Administrator
Joined
·
13,325 Posts
soooooooooooo.......if you disconnect the swirl motor it runs as if it was still connected, without dropping into limp mode? Maybe the computer needs a 'positive fail' signal before it cripples the engine. If you disconnect the swirl electrics, no 'fail' is received & the car carries on like nothing happened??????? can it be that simple, or am I not getting the jist of Pedro's post?

If its true, all that mass misery & expense - for nothing!

any willing volunteers to disconnect the plug & try it?
 

·
Registered
Joined
·
64 Posts
soooooooooooo.......if you disconnect the swirl motor it runs as if it was still connected, without dropping into limp mode? Maybe the computer needs a 'positive fail' signal before it cripples the engine. If you disconnect the swirl electrics, no 'fail' is received & the car carries on like nothing happened??????? can it be that simple, or am I not getting the jist of Pedro's post?

If its true, all that mass misery & expense - for nothing!

any willing volunteers to disconnect the plug & try it?
The Chryler assist guy that sorted me out roadside when my swirl failed did just that. He unplugged and let me carry on home, 200 miles away so I could sort it out with my local dealer.

It felt like I was driving an old transit , not a lot of power and poor throtle response, but if you kept your foot down you would still get up to legal limits no problem

My mpg only dropped by a couple of miles per gallon and so long as I remembered I was down on power driving around was no real problem.

After saying all that, I'm not volunteering to unplug it and give it another go :biggrin:
 

·
Registered
Joined
·
36 Posts
Discussion Starter #23
If u got a diagnostic tools at home...give a try.....
With swirl motor disconnected and clear the codes my car has no differences in driving....the kick down working normal....changing gear is very normal.....no limp mode.....
Peterr is right......I KNOW THIS TRICK FROM A CHRYSLER MECHANIC......soooo ?????Is this a way to take our money out of packet?.........
.....
Is there any volunteer ???/?...
so.....next time..if u got prob with the swirl motor...just disconnect it....and if u got a diagnostic ,will be better.......remember that, not stop the engine for that trip...the MIL..is coming up....
By the way....ai drove the car in half term holiday... in Europe with that MIL on my dash board for 3200 miles...No limp mode......(P2008 --swirl motor not working sure)....my car did normal...130 miles/hour (Germany).......Now(after fire on swirl motor) if I am clear the codes before trip...I can feel the car respond better than with MIL on dash board.........
Kaiser Bill...you live at 3 hours from me......?.......
I never had another 300c CRD...to make difference....but soon hope to get one....
Maybe today, or tomorrow I will change the swirl motor..an all gaskets for turbos...
Have a good day...All.......
 

·
Administrator
Joined
·
13,325 Posts
If u got a diagnostic tools at home...give a try.....
With swirl motor disconnected and clear the codes my car has no differences in driving....the kick down working normal....changing gear is very normal.....no limp mode.....
Peterr is right......I KNOW THIS TRICK FROM A CHRYSLER MECHANIC......soooo ?????Is this a way to take our money out of packet?.........
.....
Is there any volunteer ???/?...
so.....next time..if u got prob with the swirl motor...just disconnect it....and if u got a diagnostic ,will be better.......remember that, not stop the engine for that trip...the MIL..is coming up....
By the way....ai drove the car in half term holiday... in Europe with that MIL on my dash board for 3200 miles...No limp mode......(P2008 --swirl motor not working sure)....my car did normal...130 miles/hour (Germany).......Now(after fire on swirl motor) if I am clear the codes before trip...I can feel the car respond better than with MIL on dash board.........
Kaiser Bill...you live at 3 hours from me......?.......
I never had another 300c CRD...to make difference....but soon hope to get one....
Maybe today, or tomorrow I will change the swirl motor..an all gaskets for turbos...
Have a good day...All.......

I live 3 hours from everybody!
 

·
Registered
Joined
·
36 Posts
Discussion Starter #25
Good evening, Good morning......ALL OWNERS OF 300C CRD....
ANYONE FROM THIS FORUM HAD A SWIRL-MOTOR IN HIS HAND?
JUST I WANNA TELL YOU THAT.....THERE IS A SINGLE HOLE FOR OIL TO GET IN INTERIOR OF SWIRL MOTOR....THE CONNECTOR ITSELF...
TRY TO SHOW YOU ALL 2 PICS.......
SO....IN ORDER TO PROTECT OUR CARS...REGARDING THIS ISSUE IS THE ELECTRICAL PLUG (CONNECTOR).....NOW I UNDERSTOOD WHY MY SWIRL CAUGHT FIRE....WHEN I USED THAT ELECRIC CONTACTS CLEANER....


Uploaded with ImageShack.us


Uploaded with ImageShack.us
 

·
Administrator
Joined
·
13,325 Posts
So the oil that drips on it can only get inside by traveling up through the connector?

Hmmmmm :33:

The flat end of the motor in the last pic is the top....so if the connector is the entry point, its acting as a funnel!
I must admit, its not what I thought....I had it in mind that the galvanised disc on the other end was sitting in a pool of oil, which then climbed up inside the housing. When you see the motor from the top, with that female connector, it does open your eyes to other possibilities
 

·
Registered
Joined
·
112 Posts
Ok,I disconnected the swirl motor and went for a 10 mile drive, a mixture of A+B roads and short bit of dual carriageway.no sign of any warning lights but power delivery is flat but alot better than limp mode.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #30
Hello again everybody.....
Yes today I did change the swirl motor.....Took me 5 hours.....
New swirl-pot-motor....2 new plastic clips..and all gaskets for turbo as u can see in the pics...
Now the problem is worst than yesterday...(with a swirl disconnected ).....
I`ve got new codes P2015..and P1408...AND........limp mode yes....I can`t believe there is any prob again with swirl motor....no way.....Maybe the seal...Turbo.....and another pipes........
If there is anyone , had this before and cured without Chrysler hand please let me know..I need help....


Uploaded with ImageShack.us
You can see what happen to me..a few days ago.......The swirl motor has got oil inside....pretty much..
Cheers..
Nice weekend to all....
NO break down....................
 

·
Registered
Joined
·
2,407 Posts
Hi Pedro, I may be getting this problem, my ETC light came on yesterday, then went off on the return journey and hasn't been on today. Looked at the Intake pipe as per KB's advice and what do you know.... Oil. I'll be keeping a close eye on this one to see how you get on. You're a brave man tackling it yourself!! I'll be getting a catch can for sure!!! ¿Eres Español?
 

·
Registered
Joined
·
36 Posts
Discussion Starter #34
Hi Pedro, I may be getting this problem, my ETC light came on yesterday, then went off on the return journey and hasn't been on today. Looked at the Intake pipe as per KB's advice and what do you know.... Oil. I'll be keeping a close eye on this one to see how you get on. You're a brave man tackling it yourself!! I'll be getting a catch can for sure!!! ¿Eres Español?
hello Radlin
Thanks for help......I keep thinking of anything to be wrong but no Swirl motor..(for a while)...
I disconnected the battery now....wait till tomorrow....
Hope to get my ECU..resetting itself....after a trip....hope so...
I got no catch can..I made one today from an aluminium can beer......hmmmmmm
Monday I will check again everything I did today......
Have a good evening
Pedro
(No I am not Spaniol nor south america......) Thanks for asking....
By the way......the catch can is good just to have a clean engine....wire,....which is good....Do not forget about the hole in connector..I cover it with foil (turkey foil)......
Cheers
 

·
Registered
Joined
·
36 Posts
Discussion Starter #36
Sorry Pedro don't speak Italian, thought you may have been Spanish - Liver there for 10 years.
Radlin....don`t be sorry......
I am from the Country of Dracula..Transilvania.... I live here now for more than 13y....
My name....both Surname and first name..Originated from South America....somewhere.....
Have a good evening....you and all ....:)
 

·
Registered
Joined
·
2,407 Posts
No, thought I ofended you!! as 'Ciao' is obviously Italian. :) Was in Romania a few years ago, Black Sea Coast, Bucharest, Transilvania (His white Castle) and Pelish Palace. :fing02:
 

·
Registered
Joined
·
36 Posts
Discussion Starter #38
No, thought I ofended you!! as 'Ciao' is obviously Italian. :) Was in Romania a few years ago, Black Sea Coast, Bucharest, Transilvania (His white Castle) and Pelish Palace. :fing02:
This is the answer from a Mercedede ) For code P2015....

Diagnostics Engineer :

Hello,
The code indicates that fuel quantity control valve does not function properly. This can be due to leaks in fuel system, clogged fuel filter, weak fuel pump, failure of the quantity control valve or even fuel injectors.
Diagnostics Engineer :

Regards, Stan

Read more: Mercedes Questions - mercedes E320 CDI code p2015 on a Merc e320CDI 55 plate engine - JustAnswer Mercedes Questions - mercedes E320 CDI code p2015 on a Merc e320CDI 55 plate engine - JustAnswer
Ped
Hope is helping......
 

·
Registered
Joined
·
36 Posts
Discussion Starter #40
Ped, are you referring to my ETC light - I had no code P2015? or to what you describe previously in the thread.
Hi Radlin..
Yes red and flashing ETC light...( sorry for so late..)....and the code P2015...
Yesterday evening.....I had a professional diagnostic..on it......The code P1408...is nothing to do with EGR valve .....Is emission filter...Now got no more P1408.The Man could clean this from diagnostic, with the engine start ....and 2000 RPM....for 6 min I think.....
He could command the swirl motor.....I think the LINKAGE from one or two inlet manifold are not working....I will let u know Saturday ...
See you soon
Ped
 
21 - 40 of 67 Posts
Top