Chrysler 300C & SRT8 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 · (Edited)
This has probably been answered before, but I can't find a thread.

I bought a REC radio from an Ebay seller. Installed it with no issues. Radio and nav functions work OK, but CD player displays a DISC ERROR message when I try to load a CD. When I push the LOAD button, it makes noises for a few seconds, then displays the error message. :eek:uch:

Any suggestions (other than returning it to the seller)?

Update, with a new thought.

I installed this radio for someone else. They had a high end alarm system installed before I got the chance to install the radio. I couldn't contact anyone at the alarm place to ask them if it was OK to disconnect the battery. Bottom line, I DID NOT disconnect the battery before installing the radio.

Could this have anything to do with the DISC ERROR message? When I plugged in the large connector in the back, the radio came to life and ejected a CD that had been left in the radio. After that, the DISC ERROR message whenever trying to load a CD.
 

·
Registered
Joined
·
268 Posts
the ejected cd

was the ejected cd yours or one that was in there from the seller? perhaps there are more cds in there that are jammed?
Jaydee
 

·
Registered
Joined
·
43 Posts
magnesium300c said:
This has probably been answered before, but I can't find a thread.

I bought a REC radio from an Ebay seller. Installed it with no issues. Radio and nav functions work OK, but CD player displays a DISC ERROR message when I try to load a CD. When I push the LOAD button, it makes noises for a few seconds, then displays the error message. :eek:uch:

Any suggestions (other than returning it to the seller)?

Update, with a new thought.

I installed this radio for someone else. They had a high end alarm system installed before I got the chance to install the radio. I couldn't contact anyone at the alarm place to ask them if it was OK to disconnect the battery. Bottom line, I DID NOT disconnect the battery before installing the radio.

Could this have anything to do with the DISC ERROR message? When I plugged in the large connector in the back, the radio came to life and ejected a CD that had been left in the radio. After that, the DISC ERROR message whenever trying to load a CD.
I would return it to the seller. The decks in those units are very sensitive. When shipped to the dealer new in the box, there is a shipping bracket located on top of the radio. This bracket holds the deck in place so it does not bounce around during shipping. I'm guessing most units from E-Bay are not going to have this bracket still on there, since it needs to be removed before installation into a new vehicle. So my guess would be the deck bounced around and has been damaged.
 
1 - 3 of 3 Posts
Top