Chrysler 300C & SRT8 Forums banner

1 - 20 of 42 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
Guys, I need some help before I replace the window regulator. The driver's window will go up or down in 2 inch increments. I replaced the memory module since before it started doing this the auto up function would not re-program and I still have the problem.

I see three parts to this system........the memory module, switch module and the regulator/motor module.

Before I spring for the regulator and have to remove the damned rtv goo that holds the plastic over the door steel has anyone experienced this? Can anyone assure me that it is the regulator/motor assembly?

HELP
 

·
Registered
Joined
·
52 Posts
Discussion Starter #3
It acts like a short but more like a dead spot in the window motor. Sort of like the motor sending the control module into over current and thus shutting it down.

I am just hoping someone else has had the same problem before I spring for the motor/regulator setup and have to deal with dismantling the entire door.
 

·
Registered
Joined
·
42 Posts
It acts like a short but more like a dead spot in the window motor. Sort of like the motor sending the control module into over current and thus shutting it down.

I am just hoping someone else has had the same problem before I spring for the motor/regulator setup and have to deal with dismantling the entire door.

I have that problem right now, i am taking to dealership to check out as doesnt happen all the time. i will let you know what happens and what they came up with, still on warranty :grouphug:
 

·
Registered
Joined
·
42 Posts
they have me set for Friday morning, so i will post in the afternoon and let you know, also having them check the front tire rods as i feel a little play in the wheel.
Also told them i had talked to Chrysler directly about this issue and they said they had a repair stated for this. Since it is warranty, shouldnt be a issue for me, but i didnt know if you where on warranty or not, so i will get a quote on price for you in case this was an out of warranty repair for you :)
 

·
Registered
Joined
·
52 Posts
Discussion Starter #7
That would be great, because I am well out of warranty for those types of problems. I'll be tied up most of Friday so I'll look for your post Friday night or Saturday.
 

·
Registered
Joined
·
42 Posts
The Vehicle is in this morning, i let them know about the issues and will get a quote afterwards, since i still have warranty, if you have a fax #, i should be able to send you a copy of the parts needed, or i can just post them here on the site :) and i will get costs of parts and possible labor, unless you are doing labor yourself , vehicle should be done this afternoon.
 

·
Registered
Joined
·
42 Posts
I called the dealership, it definately the moduale that has to be replaced, and they has to do a reseting of the switch, is for sure something Chrysler has a notice for in the system !!! Plus as an added bonus, my Tire Rods where shot, lucky me, this was also warranty. I will get the part # and price when i get there and try to find out if this is an involved repair.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #10 (Edited)
Thanks again, I appreciate the info. If you can fax something to me feel free to send it to 503-612-7287​

I'll look forward to seeing which module they replace. If you could ask them whether it is necessary to reflash the software in the car once this module is replaced I'd like to know that for sure. I replaced the memory module with zero affect so maybe its just that I didn't take it into the dealership to have them do that.​

Glad to see you've got your's back on line.:biggrin:​
 

·
Registered
Joined
·
42 Posts
repair didnt work, i will fax the info i have today, sorry it took me so darn long :( the tire rods went great :) and the drivers window wroks fine, but the passenger side still not working properly.

I'll fax what i got though and i'll circle the part #
 

·
Registered
Joined
·
42 Posts
i faxed 2 times, hope it works out, they couldnt reprogramm the module and i think thats why it isnt working, they said to get back to them on it if it still wasnt working and they could try another thing, i will check this out also

once again , sorry for the wait
 

·
Registered
Joined
·
52 Posts
Discussion Starter #13
Thanks Chad, I did get the fax. Glad you got the tie rods fixed, mine are borderline (at 76000 miles). Maybe since yours is AWD they wear faster?

Interesting that the module would not reprogram, sounds like they were trying to keep from springing for a new one. I have a new one and it looks like I will just have to spring for the stealership to reprogram mine.

cheers,
 

·
Registered
Joined
·
42 Posts
Yah, i dont know why it still isn't working, but i will have checked out again on friday :) The tire rods is weird, but is a notice for it on Chrysler, and mine is an SRT 8, no AWD so i dont know, think maybe just from factory they were bad ? As soon as i find out what else i need, i'll let you know
 

·
Registered
Joined
·
52 Posts
Discussion Starter #15
I'll be curious to hear the outcome. I am still living with the 2 inch increments.

Sorry about the AWD vs. SRT8...............I read the invoice that they gave you and they list it as an AWD. Should have read your bio and I'd have known.

Good luck
 

·
Registered
Joined
·
38 Posts
window problem

so what was the final outcome of the window prroblem. I have a 06 300C that the driver side window only goes up or down 2 inches at a time. Was it the mod and is there a recall that the dealership will fix for free? If not, how much was it for the dealership to do? Thanks Strats
 

·
Registered
Joined
·
42 Posts
so what was the final outcome of the window prroblem. I have a 06 300C that the driver side window only goes up or down 2 inches at a time. Was it the mod and is there a recall that the dealership will fix for free? If not, how much was it for the dealership to do? Thanks Strats
Any more news on this I have the same problem.
 

·
Administrator
Joined
·
23,436 Posts
Any more news on this I have the same problem.
Dan, have you tried the window recalibration? It may be as simple as that before you need to go any further. This is a very common occurance and it also needs to be done after a battery disconnect.

Drive the window all the way down and hold the button for a few seconds, then drive it all the way up and hold it for a few seconds. If that doesn't work you may have to go the module route as well.

Bernie
 

·
Registered
Joined
·
42 Posts
Thanks Bernie, I have tried the window recalibration, but with no change. Looks like I will have to call the dealer regarding the TSB. I shouldn't complain the vehicle has been worry free since July/04 when I bought it.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #20
Dan,
Let me know what your dealer tells you. I'm still living with the problem and just last week hit 3 deer so don't even have the car right now. I'd like to get it fixed but don't trust my dealer. He's attempted to fix more than needed fixing on the car before.
 
1 - 20 of 42 Posts
Top