Chrysler 300C & SRT8 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys, did some research and still cannot pinpoint the exact root of this issue I'm currently having. 2006 Chrylser Touring. Noticed the other day while driving no matter what the speed may be, when I let off the accelerator and press it again I hear a single "click" sound coming from passenger side. I know this is not a lifter issue. Drove back home had a friend hit the accelerator while it was in park and the click is coming from what seems to be the area right around the EGR Valve location on the passenger side of the engine. Just to mention again this is only one single click each time the accelerator is pressed. No lack of power noticed and no decrease in fuel mileage. The only other issue would be on occasion while at a stoplight during idle the car wile drop down about 100th RPM but then will come right back up to the normal idle speed. Has anyone ever heard of an EGR valve producing a click or could it be a possible misfire occuring? No notification lights have come on the vehicle so its not throwing out any codes and its been consistent now for about 3 weeks. Thanks guys for taking the time out to read!!!
 

·
Registered
Joined
·
778 Posts
Well, I am no means an expert or anything like that. But no one has commented anything yet so I'll try... haha

I had an 06 300 Touring as well, I haven't heard anything like a click that could have been possibly coming from the passenger side, but I do remember hearing when I would accelerate aggressively (for a V6) that the Throttle body would click in (or at least that's what someone told me... :/ ) but for any other normal acceleration I didn't hear anything like that.

And as for the stop light RPM, mine used to do that too.. sometimes it'd drop enough that I'd thought the engine was going to die out..

Sorry that I couldn't be of any help, I've also recently traded my 06 touring in for a 13 C... So I got rid of it before anything had happened further with it. (had roughly 155,*** miles on it.)
 
1 - 2 of 2 Posts
Top