Chrysler 300C & SRT8 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
After replacing my battery in my 2006 300 V6 Chrysler I stupidly tried to connect the terminals wrong way around.
This has caused some electrical issues.
Steering wheel buttons won't work, wipers, turn signals, gears won't change etc.
Is it the ECU or something else??
 

·
Registered
Joined
·
134 Posts
Sad news mate, and so many things that would/could be fried.

The problem is, if things are shorted, and you don't replace them, the parts you DO replace could be overloaded/blown by the fried parts not replaced.

Anything with electronic control likely damaged; and in these cars that is everything.

I would check alternator as well. All the diodes in that are reverse biased when connected correctly. But they are ALWAYS connected, but don't conduct reverse, only when charging. Reverse/wrong connection means entire battery power shorted to earth through all diodes, and they normally blow before a fuse/fusible link, but worth checking.

If they blow "open"; then alt just won't work. But if they blow and short, then battery will short as soon as connected. If it has blown a few (open) then alt will work but reduced current capacity.

But your electronic issues are the bigger headache.

Sorry to just echo stuff you probably already know.

But be very careful. If you replace ECU; any damaged components could in turn damage THAT when ign turned on.

Again, probably just telling you what you already know/obvious.
 
1 - 3 of 3 Posts
Top