Chrysler 300C & SRT8 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I am new to this site but am looking for help on an issue with my 2005 Chrysler 300.

My issue is that when driving down the road the SPEEDOMETER, TACHOMETER, FUEL GAUGE AND ALL OTHER LIGHTS AND GUAGES will turn off then usually right back on. Recently the BAS/ESP light came on after the system reset. When this all happens the heater shuts off as well. The auto headlights have also recently started turning right off but i can put in Manual and they work fine!

I have had it in for service several times and they say there are no codes! Does anyone have similar experiences.

Thanks in Advance for any help.
 

·
Registered
Joined
·
8 Posts
I am new to this site but am looking for help on an issue with my 2005 Chrysler 300.

My issue is that when driving down the road the SPEEDOMETER, TACHOMETER, FUEL GAUGE AND ALL OTHER LIGHTS AND GUAGES will turn off then usually right back on. Recently the BAS/ESP light came on after the system reset. When this all happens the heater shuts off as well. The auto headlights have also recently started turning right off but i can put in Manual and they work fine!

I have had it in for service several times and they say there are no codes! Does anyone have similar experiences.

Thanks in Advance for any help.
by the sounds of other posts similar, you may have to change your battery, your car reacts in funny ways with a low battery
 

·
Registered
Joined
·
1,140 Posts
could be a loose connection check the battery cables and how long has your battery been installed if its the original it s about time to change it as these cars do some weird things when your battery is about to die they don't work well with lower than normal voltage
 
1 - 3 of 3 Posts
Top