Chrysler 300C & SRT8 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
375 Posts
Discussion Starter · #1 ·
It happend the second time in one month on 2006 300C as I was breaking on an exit ramp from a freeway. The ramp is type of zig zag. Recommended speed about 30 mph. I entered on the ramp at about 75 mph slowing down to 50+ mph by the time to enter the second turn on the ramp.

I realized it was a bit too fast and started to break to slow down while already in the second curve. Is was increasing pressure to stop in front of traffic light, but not strong enough to leave skid marks or anything.

The car shut down a few moments before I stopped. I would say I heard chime about 2 seconds before I came to complete stop. The same thing happened about a month ago in very similar circumstances. Any ideas?
 

·
Registered
Joined
·
375 Posts
Discussion Starter · #3 ·
Jasper said:
There's a few threads running here about stalling - some at idle (idle undershoot) and some stalling on turns. Try reading through these two to get you started:

http://www.300cforums.com/forums/showthread.php?t=6620

http://www.300cforums.com/forums/showthread.php?t=1609

Hope this helps! BTW, I have a 2006 300C, build date 3-31-05 @ 8AM, and haven't had any stalling issues (yet!). :wave:

My C was built May 14th. I am in GTA so it was just couple weeks before it ended up in my hands.

I did make sharp wheel turns both times engine stalled. Both times on a ramp in very same driving conditions. Different ramps.

I am asking dealer to investigate this and run tests, as I have to get a new rocker moulding on drivers side. Lost it last weekend as I jumped on a curb stone dividing parking lot. No damage to the body, but $420 Canadian for a new piece of plastic painted and installed. Is not it a rip off? :( Did not see the stone at dusk and no cars were parked around it.
 
1 - 3 of 3 Posts
Top