Chrysler 300C & SRT8 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
476 Posts
Discussion Starter · #1 ·
I have had a tapping noise on my Silver 06' SRT-8 since day one and assumed it was normal until I thought about it the other day while driving my Black 05' SRT-8 when I subconciously recognized that it wasn't tapping.

Does anyone else have this noise. I can hear it clearly when parked close to a wall and can hear it if I bend down and listen at the wheel wells. Reminds me of a lifter tapping.
 

·
Registered
Joined
·
482 Posts
Back when I was under attack for Amsoil and anything else some of the others around here could think of, I had mentioned we had a tick in ours. It is gone now and it wasn't since day one, but it is identicle to the tick that we have in our Hemi Ram and it has had it since day one. It only does it once warmed up, only while at idle speed(disappears with even a slight increase in RPM), and new oil seems to quiet it down a bit(still audible, but decreases in level). If yours was similar, take it do a dealer and see if they can duplicate it. Our truck duplicated it for them on many occasions and they never did anything to fix it. There are a large number of posts about the 'hemi tick' in some of the other forums dedicated more towards the trucks and a lot of people have it. I gave up on the dealer and started mod'ing ours, as the tick seems to have little to no affect on it(I am sure it isn't good, no DCX information has ever been located on it, so I assume that it isn't fatal).

Our SRT8 did it for about 4 days or so and I haven't heard it since. It had about 4K miles on it when it appeared briefly.

Todd
 

·
Registered
Joined
·
77 Posts
I have seen many threads on this and personally had the tick since aprox 5000K miles. I am very sensitive to engince noises/vibrations and still remember the day, that I started it and there it was....just like a tappet tick tick ticking away on one side. It does it sometimes cold, sometimes warm. I can rev it a couple times and it goes away....then comes back later...very inconsistent but always comes back eventually. I am willing to live with it if someone can explain it as something that is not going to be harmful in the long run but something tells me its a design flaw in one of the components and not present in all hemi motors.

Thoughts?

Chris
 

·
Registered
Joined
·
482 Posts
The 'hemi tick' as described on the other forums is only apparent after the engine warms up. It is not a symptom during warm up, so I'm not sure if that is the same thing Chris.

I think you guys could Google "hemi tick" and run across links to many of these forums where it has received a great deal of press from members. Dodge has always returned a 'its a normal feature of the 5.7L Hemi' on service reports from everyone I have seen post about taking it in. My service reports are the same, 'normal feature of the Hemi motor.'

Todd
 
1 - 4 of 4 Posts
Top