Chrysler 300C & SRT8 Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
My Evic is running rev. 4.04 dated Feb 7, 2005

- Does the TSB to fix the "alien" characters in the Oil Pres. & Temp. display update the software version?

- Does anyone have a more up to date version?
 

·
Premium Member
Joined
·
3,499 Posts
raka said:
My Evic is running rev. 4.04 dated Feb 7, 2005

- Does the TSB to fix the "alien" characters in the Oil Pres. & Temp. display update the software version?

- Does anyone have a more up to date version?
Just brought 'DESIREE' home today from having the 'resonance' at 55 MPH problem fixed.
EVIC still shows v 3.61, 7/27/04.
 

·
Registered
Joined
·
323 Posts
raka said:
My Evic is running rev. 4.04 dated Feb 7, 2005

- Does the TSB to fix the "alien" characters in the Oil Pres. & Temp. display update the software version?

- Does anyone have a more up to date version?
Raka, from my understanding you are the first on the board to have the new software. My guess is that this code fixes the alien characters as most people got them from upgrading to 3.61. I wonder what else it fixes? Anyone with some inside knowledge know?
 

·
Registered
Joined
·
281 Posts
I would like to know if this version can be loaded in a 2005 running 3.60 currently.

It seems somewhere I saw additional features have been added like Oil Temperature. I would like to know that.
 

·
Registered
Joined
·
55 Posts
I also have the version 4.04 and I still have the "alien characters". I called dealer and have it going in monday. I would also like to know before I take it in, if there has been a fix for this. It also occurs in the mph screen in the "easter egg".

AGGOST
Damon
 

·
Registered
Joined
·
96 Posts
Interesting...I will have to check my EVIC to see if I have any strange characters running around :p

Anyway, what kind of aliens should I be looking for :confused:




OK enough messing around...i'll take a look at mine to see if I have any of these and see if I have a oil temp setting.

I should have the latest and greatest version of the EVIC.
 

·
Registered
Joined
·
21 Posts
pcm

Had my PCM flashed yesterday when I had my C in for a transmission fluid leak (which they fixed "replace tran connector adapter"). It says "flash program PCM to current version"

My EVIC still says 3.54 though. Other threads have said that the EVIC display only shows the EVIC software version, not the PCM (or any of the myriad other programs).

Is this correct? did they flash me?
 

·
Registered
Joined
·
182 Posts
I can always tell when someone flashes me... :D
 

·
Premium Member
Joined
·
829 Posts
stillalivenwell said:
Had my PCM flashed yesterday when I had my C in for a transmission fluid leak (which they fixed "replace tran connector adapter"). It says "flash program PCM to current version"

My EVIC still says 3.54 though. Other threads have said that the EVIC display only shows the EVIC software version, not the PCM (or any of the myriad other programs).

Is this correct? did they flash me?
EVIC only shows EVIC version and nothing else. This has been a source of confusion for some time. You can only see the other module versions with a StarScan.
 

·
Registered
Joined
·
104 Posts
Hey gang,

I have a Touring...

Is the EVIC in the Nav Unit, or in the dash display?

I have the simple dash display, so that's why I'm askin...
 

·
Registered
Joined
·
252 Posts
its in the dash display. which only shows up in the C's if i am correct. i had a base that didnt have it
 

·
Registered
Joined
·
104 Posts
Ok, thought so...I'm thinkin about buying a factory Nav unit from Ebay...

Just wondering how often the Nav software is updated, and I didn't know if they were the same thing (EVIC, Nav).
 
1 - 12 of 12 Posts
Top