Chrysler 300C & SRT8 Forums banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
255 Posts
Discussion Starter #1 (Edited)
I have a 300C gauge cluster I dont need. There is no front glass and I highly doubt you can buy just the clear piece of plastic.

Besides that everything else is there and in perfect condition. So if you need needles , electronics , or just a cluster to expierement with its perfect.


I purchsed it for $120 in a so far failed attempt to get the chrome trim rings on my touring. Its yours for $75 shipped.









 

·
Banned
Joined
·
5,754 Posts
base owner can upgrade it is plug and play, they can move their plastic "glass" cover over..


FYI 2006 plus clusters are not compatible on 2005 cars.. different hardware..

2006 - 2007 are compatible,

2008 changed hardware again..
 

·
Registered
Joined
·
255 Posts
Discussion Starter #3 (Edited)
^ And just so people are clear.... Putting your base "glass" on the 300C cluster will not give you the chrome trim rings. Unfortunately the "glass" is glued to the black bezel the chrome rings are on. With some strong ass glue. lol

Not knowing this I purchased a cluster that already had cracked "glass". After sadly discovering the "glass" and trim ring bezel are permanantly attached. I tried to just pry the "glass" off my touring cluster and I cracked that too. It can be done easily if you cut it off instead of pry like me. Too late for me since now I dont have a donor "glass". I have to buy a new one anyway so Im selling this one to lessen the blow to my wallet.

So you will get the black plate with the chrome rings. You will just have to surgically remove the "glass" from another cluster to use it.


Mr. I - Are you saying that if you plug a C cluster with EVIC into a base it will work plug and play? All functions? And will the speedo be an issue since its a 160MPH ?

I read an old post of your were you state you had issues after swapping a cluster?
 

·
Banned
Joined
·
5,754 Posts
^ And just so people are clear.... Putting your base "glass" on the 300C cluster will not give you the chrome trim rings. Unfortunately the "glass" is glued to the black bezel the chrome rings are on. With some strong ass glue. lol

Not knowing this I purchased a cluster that already had cracked "glass". After sadly discovering the "glass" and trim ring bezel are permanantly attached. I tried to just pry the "glass" off my touring cluster and I cracked that too. It can be done easily if you cut it off instead of pry like me. Too late for me since now I dont have a donor "glass". I have to buy a new one anyway so Im selling this one to lessen the blow to my wallet.

So you will get the black plate with the chrome rings. You will just have to surgically remove the "glass" from another cluster to use it.


Mr. I - Are you saying that if you plug a C cluster with EVIC into a base it will work plug and play? All functions? And will the speedo be an issue since its a 160MPH ?

I read an old post of your were you state you had issues after swapping a cluster?


dude:

hate to tell you the Glass is not held on with glue, it is held on with 12 Torx screws from the back.. look at the outer edges of the cluster from the rear, see the "silver" Torx screws? those are there to hold the glass.. that is all they do..

no glue on the Glass AT all..

and as for the chrome trim rings.. those are held in place with a plastic rivet, you have to razor blade that off and the rings then pop right off... :biggrin:


I have disassembled several clusters.. ain't no big thing, and there is NO glue on them.
 

·
Banned
Joined
·
5,754 Posts
^ And just so people are clear.... Putting your base "glass" on the 300C cluster will not give you the chrome trim rings. Unfortunately the "glass" is glued to the black bezel the chrome rings are on. With some strong ass glue. lol

Not knowing this I purchased a cluster that already had cracked "glass". After sadly discovering the "glass" and trim ring bezel are permanantly attached. I tried to just pry the "glass" off my touring cluster and I cracked that too. It can be done easily if you cut it off instead of pry like me. Too late for me since now I dont have a donor "glass". I have to buy a new one anyway so Im selling this one to lessen the blow to my wallet.

So you will get the black plate with the chrome rings. You will just have to surgically remove the "glass" from another cluster to use it.


Mr. I - Are you saying that if you plug a C cluster with EVIC into a base it will work plug and play? All functions? And will the speedo be an issue since its a 160MPH ?

I read an old post of your were you state you had issues after swapping a cluster?


2005 models have issues with 2006 clusters..

2006 and 2007 clusters work in either a 2006 or 2007 car..

yes if you plug an EVIC cluster into a base model the EVIC will work, not all features with work because you may not have them installed. (home link screen for example) but the cluster will work fine, and it will calibrate itself; so going from a 140mph speedo to a 160 is not an issue, same with going from a 160 to a 180 SRT cluster..


2005 models built before 08-2005 can not use 2006/2007 clusters. as the hardware changed and the cluster can not read the old data coming from the PCM and TCM..
 

·
Registered
Joined
·
255 Posts
Discussion Starter #8
dude:

hate to tell you the Glass is not held on with glue, it is held on with 12 Torx screws from the back.. look at the outer edges of the cluster from the rear, see the "silver" Torx screws? those are there to hold the glass.. that is all they do..

no glue on the Glass AT all..

and as for the chrome trim rings.. those are held in place with a plastic rivet, you have to razor blade that off and the rings then pop right off... :biggrin:


I have disassembled several clusters.. ain't no big thing, and there is NO glue on them.

Mr. I either your misunderstanding me or Im misunderstanding you. I posted pics above.

When I say glass I literally mean just the glass. As you can see above everything is there except the glass. That glass does not screw to the black bezel it sits on. It is glued for sure. I scaped it out myself after I tore out the orignal cracked glass. If theres screws holding that on I cant see them.

The mistake I made was trying to pry the glass off my Touring cluster. I was going to put it on this one, but I cracked it. If I would have just sawed it off with something instead it would have worked easily.

Also I didnt know the chrome rings would come off if I removed that rivet. It sure doesnt look like they come off, but I will take your word for it. I knew I should have specifically asked you first before doing this mod.

Either way I still have to buy a new cluster now because I dont have any glass to use for a donor.

One more question for you? I have a new cluster on the way with almost exactly the same milage as mine. Just a little more. If I just swapped the whole cluster out at the exact same mileage is there any legalites I have to worry about? When I take my car to the dealer will they get some code or something?
 

·
Registered
Joined
·
463 Posts
MArc you are an incredible guy you know EVERYTHING and I repeat EVERYTHING there is to know about the beast known as the 300, What the hell. LOL


can I use the glass from my current bsae cluster?
 

·
Registered
Joined
·
116 Posts
The only potential problem with this going on my base is the change of the odometer reading... right Mr. I? I think I read where you posted that earlier....
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top