Chrysler 300C & SRT8 Forums banner

21 - 38 of 43 Posts

·
Registered
Joined
·
179 Posts
I put the new computer in my 300c and fixed the stalling issues. The ecm was bad. 250-300 for a gone threw one. Chrysler cant get them anymore for the 05-2007 so you have to go threw the refurbished rout. Mine came plug and play for 300 bucks. Car hasnt stalled in a month and every thing works great now. Just an update. It was getting so bad i couldn't drive one min without it stalling some times. It would just die as your describing.
 

·
Registered
Joined
·
19 Posts
I went ahead and replaced the pcm and tcm and it fixed my stalling issue. This was such an easy fix took me only 1 hour to change both. Watch some YouTube videos and it's cake. I also purchased my computers from a third party and saved a lot of money from the stealership.
 

·
Registered
Joined
·
11 Posts
Great news! I kinda figured thats what i was gonna have to do anyways. so next problem will be finding one. i dont want a stock computer/tune id rather upgrade than replace if you know what i mean

Sent from my SM-N910P using Tapatalk
 

·
Registered
Joined
·
2 Posts
I put the new computer in my 300c and fixed the stalling issues. The ecm was bad. 250-300 for a gone threw one. Chrysler cant get them anymore for the 05-2007 so you have to go threw the refurbished rout. Mine came plug and play for 300 bucks. Car hasnt stalled in a month and every thing works great now. Just an update. It was getting so bad i couldn't drive one min without it stalling some times. It would just die as your describing.
Whipper300, I have been having the same problems for a year or more.. I have tried changing most everything, I have chased down all my wiring and checked all the grounds I can find. Seems as though when I replace something with new it runs better for awhile and then it comes back and starts stalling again and again. Thank you for your post here, I have been trying to research for a long time.. It is getting worse the more I try and drive it.. Where were you able to buy one from?? I need to get one for mine as all your symptoms sound the same as mine... Thank you in advance..
 

·
Registered
Joined
·
4 Posts
I have a 2006 300c with the exact issue that lots are having, rendomly dies and bucks and jerks.. Have removed the alt and tested good, traced and cleaned all grounds under hood, in trunk, and all i could find behind the dash and under the seats. Always have code u0100 and p0700. scanned tcm and its always just a loss off comm code, Replaced the pcm with rebuilt unit and everything was good for almost a month and then is started acting up again. Company I got pcm from replaced it and the new one seemed to fix the concern for a couple days and now its back to bucking and jerking. CEL light does not always com on but when it does its just the same two codes for loss of comm. Im beating my head up against a wall here. Dealer states cant verify cause they dont drive it enough. Finny thing is the original pcm I could start the car and it would die at a idle all the time, not had that issue with either rebuilt pcm's. I have researched online and it seems no one has a good answer as to what is wrong with it. I almost forgot, last time it did it to me I lost the cruise, had to pull over and restart the car and the cruise started working again.
 

·
Registered
Joined
·
4 Posts
Well I have a new update. Replaced all a coil's and replace the TCM in the vehicle still randomly will die while sitting at an idol or at a stoplight and will still continue to bark and jump randomly a few times up to 10 or 15 times after you have just restarted the vehicle and after it finally quit doing it you can drive for hours without any problem whatsoever. I do notice that when it seems to do the barking and jumping acting like you've turned the key off when you're driving at night with the headlights on the headlights I'll get them then I get really bright and then they come back to normal like it's got some sort of a voltage surge going on so I guess my next step is replacing the alternator. I do find it funny that so many people on different forms are having the same issues out of the Chrysler 300 is the Dodge Chargers and yet nobody has a hard fix known
 

·
Registered
Joined
·
2 Posts
I have same exact problem with my 2006 Chrysler 300C 5.7 Hemi. PCM and TCM were replaced and still the same codes come back. I also noticed that after filling the tank with gas car immediately shuts off after trying to drive away from gas station. After lots of research I found that Chrysler has a defect inside the fuel tank with a purge valve that gets stuck and causes liquid fuel to back up the EVAP system causing the engine to stall. The engine codes are generic and are set when the PCM sends a command to the purge valve and the EVAP system becomes flooded with liquid gas causing the engine to stall. Chrysler knows about this problem and extended the warranty on the 19 gallon fuel tank for a lifetime. They put out a bulletin on the X-53 fuel tank that is the cause of stalling on most vehicles manufactured with this particular fuel tank and the only solution is to have them replace the tank with a revised one. They are very well aware of this situation and I am still fighting with them for months now to try and get it replaced under their lifetime warranty.
Do a google search of X53 fuel tank bulletin to see this warranty. I have a strong feeling that this faulty valve inside the fuel tank is the main cause of the stalling issue. Please let me know if anyone finds out the cause. Good luck to all who have the same issue!
 

·
Registered
Joined
·
179 Posts
It was 100% my computer under the hood. i plugged it in and for almost a year now driving like a dream problem solved. PCM Sorry about the delay Ive been ill and not doing much. But all better now and so is the Car!! Im just trying to buy tires for the challenger srt wheels now. i did all the same as you except TCM. lol get a new computer and get back to trouble free driving torkmonstr
 

·
Registered
Joined
·
179 Posts
I have already replaced the pcm twice and to date still having the same issue.
The only other thing that i can think off was the gas tank recall. i dont have the numbers that were recalled I had mine done. You just have to say My car is stalling and im afraid im going to get hurt its not safe and they will replace your gas tank. These same symptoms were same as PCM failing. Mine stalled out the other but just never dies. sputtered then died. Was crank position sensor. Replaced 30 bucks good to go. Im not sure what else it could be. Sorry There is a thread on gas tank recall you might want to read threw. its really very much the exact same issue.
 

·
Registered
Joined
·
23 Posts
I have same issue, gonna replace PCM asap. Hopefully that fixes issue. Will the vapor valve issue in fuel tank give u0100 and p0700 codes though? Debating having my tank swapped them PCM to possibly save $300. I'm doubtful car would throw those codes for tank issue but pls lmk, thanks
 
21 - 38 of 43 Posts
About this Discussion
42 Replies
22 Participants
Hemicar345
Chrysler 300C & SRT8 Forums
Join the 300c forum community to discuss the Chrysler 300c, SRT8, horsepower specs, AWD system and so much more!
Full Forum Listing
Top