Chrysler 300C & SRT8 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
931 Posts
Discussion Starter #1
well im not sure if its just coincidence or not. but the second day that i have had the S/C on the car, i got a CEL. i hooked up the predator, to read them. and i have 2 codes. for right and left catlytic efficiency. i cant remember the numbers off hand.

im going to try and turn off the second O2 sensor with the diablo tonight. is this easy to find?? ive played with my diablo a bit. but i have never noticed where to find this option, or the fan settings either.
 

·
Registered
Joined
·
1,182 Posts
one word ...

UPDATE

your diablo needs major update , i used to have the same O2 issue and i updated the predator and now im golden :) , what u have isnt a major issue :) btw u got headers on ?
 

·
Registered
Joined
·
931 Posts
Discussion Starter #4
one word ...

UPDATE

your diablo needs major update , i used to have the same O2 issue and i updated the predator and now im golden :) , what u have isnt a major issue :) btw u got headers on ?
nope no headers. from what i have read, the stock headers give max flow. thats why they dont make aftermarket shorties.

since i have the vortech tune, im not sure if there is anything special i need to do to update?? but i was playing with the predator the other night. and it has the 4 different shift modes in it. so i thought it was updated. because this was the only thing i really gained by updating my old predator.

on my original predator,(when i was N/A) i never had the CEL issue. and i ran the original tune, right up until a few months ago.
 

·
Registered
Joined
·
931 Posts
Discussion Starter #6
The CEL was from my O2 sensors. i said this in my first post. the CEL went away on its own after awhile. and now its back again. i would like for someone to tell me where the option is, for turning off the rear O2 sensors, on the predator. because i havent found it yet.

also, i havent been able to update my predator. because i accidentally gave my power adaptor, to the guy who bought my original predator. and for some reason the vortech, didnt come with the adaptor. i havent had a chance to go pick up a new one yet. maybe in the moring when i get home from work.

and for anyone that cares, i have decided to go with a CMR tune. i just need to get a laptop now. so i can do some datalogs. ill post results when i get it done.
 
1 - 6 of 6 Posts
Top