Chrysler 300C & SRT8 Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter #1
I just upgraded this week from my 2006 SRT8 to a 2013 SRT8. What an improvement!!! Has there been any movement from Mopar on a fix for the P0471 code with an aftermarket exhaust. I know I can get a CMR tune to remove it, and will go that route if no other options are available. Thanks!
 

·
Registered
Joined
·
7 Posts
P0471 Error is annoying and useless

I have the Magnaflow exhaust on my 2013 SRT and I get the P0471 error every now and again. I am unable to reproduce it at will but it happens enough that I keep my OTC scanner in the glove box to clear it.

I would be nice of Chrysler to update the ECM for those that have aftermarket exhaust as they offer a system in the Mopar catalog. I can't imagine that system doesn't cause this same error.
 

·
Registered
Joined
·
229 Posts
Discussion Starter #3
How long have you had the Magnaflow on? How often does it throw the code? When it throws the code does it affect the car's driveability at all? Thanks. Mine is still under warranty, so I will probably wait till i cross the 36k mile mark before i start the mods on this one.
 

·
Premium Member
Joined
·
512 Posts
My Gen 1 SRT was kicking codes after new Magnaflows and gutting the catalytic convertors.. popped in some O2 sensor spacers... good to go now, with no check engine light.
 

·
Registered
Joined
·
7 Posts
I bought the car in August 2014 with 12000 miles from the previous owner who had installed the Magnaflow exhaust.
I now have 19600 on it and I've probably had the P0471 code 5 times now.
Doesn't seem to affect driveability and it is supposed to reset itself after 5 or so drive cycles if the computer doesn't sense another P0471 issue.
However, I clear the code when I get to my destination point as I keep my OTC scan tool in the glove box.
If the MIL lamp stays lit then the car won't allow for remote start and I like having that feature especially now in the winter as the seat and steering wheel heaters are set to ON when I remote start.
Also, the car won't remote start if your low on fuel with the Low Fuel Indicator lit. Just a side note info.

Overall I like the Magnaflow exhaust. It does drone but I plan to pull the rear seats and some carpeting to install sound deadener to see if that helps. I plan to add some to the trunk also.
 

·
Registered
Joined
·
77 Posts
I bought the car in August 2014 with 12000 miles from the previous owner who had installed the Magnaflow exhaust.
I now have 19600 on it and I've probably had the P0471 code 5 times now.
Doesn't seem to affect driveability and it is supposed to reset itself after 5 or so drive cycles if the computer doesn't sense another P0471 issue.
However, I clear the code when I get to my destination point as I keep my OTC scan tool in the glove box.
If the MIL lamp stays lit then the car won't allow for remote start and I like having that feature especially now in the winter as the seat and steering wheel heaters are set to ON when I remote start.
Also, the car won't remote start if your low on fuel with the Low Fuel Indicator lit. Just a side note info.

Overall I like the Magnaflow exhaust. It does drone but I plan to pull the rear seats and some carpeting to install sound deadener to see if that helps. I plan to add some to the trunk also.

I have the same exhaust and just clear the code when it comes up. Great sounding exhaust though, I love it.
 

·
Registered
Joined
·
7 Posts
I just installed corsa extreme yesterday and got the code after flooring it. I cleared it with a scan tool and it was fine the rest of the day. It came back on today under heavy throttle. Kind of annoying if you ask me. Looks like a trinity is in the near future
 

·
Registered
Joined
·
71 Posts
Stock exhaust with a blastin' bobs resonator delete and the exhaust valves spring loaded open. I've gotten the code multiple times now. Rather annoying if you ask me. I have a trinity, but I hate seeing an engine light on a relatively new car.
 

·
Registered
Joined
·
77 Posts
Just couple of things if you have an aftermarket catback and you throw the code.

Your MDS is disabled and your ODB emissions readiness goes into not ready state, so if you get this code and clear it you wont pass inspection right away you have to get all the monitors in the ready state again after clearing this code.

Just FYI

That said I love my Magnaflow.
 

·
Registered
Joined
·
510 Posts
Flowmaster Force 2 here. I've gotten the code under WOT. Intune cleared, has yet to reoccur.
 

·
Registered
Joined
·
305 Posts
That's odd, I have a stock exhaust and pulled this code a couple of days ago.
 

·
Administrator
Joined
·
19,606 Posts
I pulled the stock muffler off my 2014 Ram 2500 with the 6.4L and saw the valve in the muffler there.

I replaced it with a Magnaflow muffler. It never threw a code.

Is the code due to a malfunctioning flapper valve or is it associated with no flapper valve present?
 

·
Registered
Joined
·
16 Posts
Is there a way to stop these codes from popping CEL's with a Trinity? My car is tuned with the Trinity and I still get these codes all the time.

Corsa Xtreme Catback, deleted resos for straight pipe and the 93 tune are the only mods. I pop these codes quite frequently, and I even have the cheat tube that Corsa provided with the catback to mitigate these issues.

Any ideas?
 

·
Registered
Joined
·
510 Posts
Only way to get it to disappear permanently is have a CMR tune remove it.

It occasionally comes on under 2nd or 3rd gear pulls for me. Annoying as hell.
 

·
Registered
Joined
·
2 Posts
After reading your comment about this, I bought the diablo tuner, but was there a specific tune you needed to remove the light? the tune that comes with it didn't keep it off. Called diablo and they act clueless.




Only way to get it to disappear permanently is have a CMR tune remove it.

It occasionally comes on under 2nd or 3rd gear pulls for me. Annoying as hell.
 

·
Registered
Joined
·
2 Posts
I just installed corsa extreme yesterday and got the code after flooring it. I cleared it with a scan tool and it was fine the rest of the day. It came back on today under heavy throttle. Kind of annoying if you ask me. Looks like a trinity is in the near future
This literally happened to me yesterday... changing the 02 sensors to see if it’s any help....
 
1 - 20 of 21 Posts
Top