Chrysler 300C & SRT8 Forums banner

1 - 20 of 28 Posts

·
Registered
Joined
·
476 Posts
Discussion Starter #1
Has anyone installed this? I just got mine in the mail and the only instructions are the wiring diagram. I'm not the best with wiring diagrams and was hoping someone could help me understand it a little more. The model I have is FLRSCH5, the seller flashed it to my vehicle before they sent it and he said my car requires the Type 3 install and that I need to cut and or splice a few wires but I'm not really seeing where?

I see where it says to cut and isolate the white/yellow wire on VS2, but I'm not sure where the Purple - Starter (+) Output and the White/Yellow - Control (MUX) Output wires go???

Any help is appreciated.

 

Attachments

·
Registered
Joined
·
21 Posts
I'm looking at purchasing and installing this myself too with the same pin-out/wiring guide onto a 2006 300c 5.7, im an electrical engineer so once mine arrives (having to import from the US to the UK) I will be better able to help :) Unless of course you have already figured this out?
Kind regards,
Hayden.
 

·
Premium Member
Joined
·
505 Posts
Wow, I thought this was plug and play system.

I'm still trying to workout which I need for my 2013 SRT
 

·
Have to be odd to be No.1
Joined
·
7,943 Posts
I got one and the dealer is putting mine in while I've got the car their for a few other things but I'm going to ask him exactly where it goes.
If that fails there is someone else here in Canberra that installed his himself so I'll be able to catch up with him to find, cause he already said he'd help me put it in but cause the car is at the dealers i didnt worry.
 

·
Registered
Joined
·
476 Posts
Discussion Starter #6
Yeah I had finally figured it out. The purple and yellow wire tap in to two wires on the back of the ignition harness. I just used some T-taps to do it, the rest was plug and play.

I removed this because I thought it was causing an issue with my tpms system which all goes through wireless control module. Come find out I just think I have aftermarket TPMS sensors that aren't compatible so I'm to reinstall the remote start.
 

·
Have to be odd to be No.1
Joined
·
7,943 Posts
Wonder if the next gen models install the same way.
Mine is in but not sure how it was done as yet
 

·
Premium Member
Joined
·
505 Posts
Wonder if the next gen models install the same way.
Mine is in but not sure how it was done as yet
Must find out being an Aussie location hey :)
 

·
Have to be odd to be No.1
Joined
·
7,943 Posts
No luck at the dealer as they couldnt get it working so will try plan B
 

·
Registered
Joined
·
8 Posts
Flashlogic flrsch5

No luck at the dealer as they couldnt get it working so will try plan B
Just follow the directions in TYPE 3 - WIRING DIAGRAM - 1 OF 1!!!

There are 2 (TWO) connectors that plug into the backside of the ignition switch.

There is a LARGER 5 pin connector and a SMALLER 8 pin connector.

LARGER 5 PIN CONNECTOR DIRECTIONS FIRST:

Splice the PURPLE wire from the FLASHLOGIC T-HARNESS into the wire coming out of POSITION 4 OF THE LARGER 5 PIN CONNECTOR.

Splice the WHITE/YELLOW wire (WHITE WIRE WITH YELLOW STRIPE) from the FLASHLOGIC T-HARNESS into the wire coming out of the POSITION 2 OF THE LARGER 5 PIN CONNECTOR.

SMALLER 8 PIN CONNECTOR DIRECTIONS:

CUT AND INSULATE THE WHITE/YELLOW WIRE (NEXT TO WHITE/GRAY WIRE).

RUNNING LIGHTS DIRECTIONS:

If I remember correctly, you splice the WHITE/BROWN wire from the FLASHLOGIC T-HARNESS into the WHITE/BROWN wire coming out of the back of the HEADLIGHT SWITCH.

MAKE SURE TO REMOVE THE HEADLIGHT SWITCH CORRECTLY.

There is a YouTube video ("2005 Chrysler 300 touring headlight switch replacement") that shows you how to remove the headlight switch.

If you are having issues disconnecting the wire connectors from the ignition switch, take it out of the dash and you will have more room.

DO NOT, I REPEAT, DO NOT GET AGGRESSIVE WITH ANY OF THE WIRING CONNECTORS MENTIONED ABOVE, ESPECIALLY THE SMALLER 8 PIN CONNECTOR!!!

I HAVE LARGE HANDS WITH BIG FINGERS.

I USED NEEDLE NOSE PLIERS TO PUSH DOWN ON THE RELEASE TABS ON THE 8 PIN CONNECTORS AND ENDED UP CRUSHING BOTH THE FACTORY AND T-HARNESS 8 PIN CONNECTORS!!!

HAD TO BUY ANOTHER T-HARNESS FROM FLASH LOGIC AND 8 PIN CONNECTOR FROM CHRYSLER!!!

IF YOU NEED TO DISCONNECT ANY OF THE 8 PIN CONNECTORS, PRESS DOWN GENTLY ON THE RELEASE TAB, TAKE A VERY SMALL FLAT HEAD SCREW DRIVER AND WEDGE IT CAREFULLY BETWEEN THE PLACE WHERE THE MALE AND FEMALE 8 PIN CONNECORS COME TOGETHER. DO THIS ON EACH SIDE OF THE RELEASE TAB.

YOU JUST NEED TO "BARELY START" THE DISCONNECTION OF THE MALE AND FEMALE CONNECTORS WITH THE SMALL FLAT HEAD SCREW DRIVER ON EACH SIDE OF THE RELEASE TAB AND THEY WILL SLIDE RIGHT OUT!!!

IF YOU TRY TO JUST DO THIS PROCEDURE WITH JUST ONE OF YOUR FINGERS ON THE RELEASE TAB AND NOT DO THE SMALL FLAT HEAD SCREW DRIVER PROCEDURE, THE DISCONNECTION WILL NOT, I REPEAT, WILL NOT COME EASILY.

Let me know how it goes.

Thanks,
George
 

·
Have to be odd to be No.1
Joined
·
7,943 Posts
Awesome write up, the big thing is I have the next gen and not the first gen so is it very much the same or totally different.
Thank you again for the details though.
 

·
Have to be odd to be No.1
Joined
·
7,943 Posts
No splicing involved on the 2nd gen. very easy and all plug and play unless you want to worry about adding the bonnet stuff. (so it wont start if the bonnet is open.)

plug for the ODBC to piggy back off
plug at the back of the start stop button pops out and piggy backs of the harness and back on.
and 2 plugs at the back of the headlight switch that does the same.
 

·
Premium Member
Joined
·
505 Posts
great info Moparlife.

Can you advise which kit (part no) is the right one to order?
 

·
Registered
Joined
·
8 Posts
Hi Moparlife,

Sorry for the delay.

I was researching the FlashLogic for your car, but got interrupted with our 2005 Chrysler 300 Limted getting locked up.

I just put a post in my thread with an update.

Had to have the car towed to the dealer VERY VERY EARLY last Friday morning.

The finally got to the car and "unlocked" it late in the afternoon. (I was there most of the day).

They got a "communications" error with the P0513 code.

Am waiting by the phone!!!

Glad to hear that your remote install will be basically "plug and play".

If you go on FlashLogic's website you can download the manual!!!

DON'T FORGET WHAT I WROTE ABOUT THE 8 PIN CONNECTORS!!!

Please keep us posted.

Thank you,
George
 

·
Have to be odd to be No.1
Joined
·
7,943 Posts
Well it works beautifully now and no probs with the connectors
 

·
Registered
Joined
·
1 Posts
Flrshch5

Have you done this yet if so can you give info on how you done it or got it done. I got a 2006 Crysler 300c myself.
 

·
Registered
Joined
·
15 Posts
My flash logic is all installed and starts the car via remote

Problem is the steering is lock when it starts with the remote any ideas

Sent from my SM-G920I using Tapatalk
 
1 - 20 of 28 Posts
Top