Chrysler 300C & SRT8 Forums banner

21 - 28 of 28 Posts

·
Registered
Joined
·
15 Posts
Iv'e just installed my flashlogic today.
And got the same problem remote start works, but the steering lock does not release.
Anyone found a way to sort this.
Thanks in advance.
 

·
Premium Member
Joined
·
505 Posts
Hi Guys,

Looking to purchase however after viewing the site can't locate where I can order. Anyone able to provide a link for me to follow?

I'm located in Australia
 

·
Have to be odd to be No.1
Joined
·
7,943 Posts
Its flash Logic Gavin and works on the 12 and higher model years
 

·
Registered
Joined
·
4 Posts
Can anyone say for sure that the FlashLogic CH5 will work on a 2007 300C in the UK - ie with the UK required Thatcham modifications to the Can-bus system (whatever they may be). If anyone in the UK has fitted one and can confirm, that would be great.

TIA
 

·
Registered
Joined
·
15 Posts
Mines an 07 and i can confirm the flashlogic ch5 will not work fully.
You still have to turn off and back on to release steering lock, which seems a bit pointless.
Ive not heard of any mods to the system to rectify this.
 

·
Registered
Joined
·
4 Posts
Thanks very much for the info. Clearly, it would be ideal if I did NOT have to do that but not necessarily a deal-breaker for me, as the point of remote start for me is to warm the car up without leaving the house, or when the train pulls into the station before walking to the car park - so turning the key off then on again to restart is a 2 second job.
 

·
Registered
Joined
·
4 Posts
I fitted it and remote start does work, but I have an odd problem: once the car is remote started the factory key will not unlock the car by the buttons. I have to use the physical key in the passenger door then hit the central locking button inside the door, so I can go round to the drivers side and get in. Does anyone else have this problem?

I was also supplied a Prestige Range extender but it came with no instructions. In the box was a lead adapter with a red and black breakout flylead. I assume this requires vehicle permanent live, but I am loathe to put voltage to it without instructions in case it is some kind of external trigger. As it stands, with no voltage applied to that lead, it ill not recognise the two remotes that came with it.

I have asked the supplier for help on both these issues and waiting for a response.
 
21 - 28 of 28 Posts
Top