Chrysler 300C & SRT8 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,305 Posts
Discussion Starter #1
I know this has been addressed before but I tried to search and couldn't find anything. My car develops a shake around 80mph on the highway. I can feel it in the steering wheel and if I were to let it go I can see it shaking. I had an outter tie rod replaced a few months back by the dealer because it was worn out at around 31k and at this time they replaced seals on my rear end as well.


Any thoughts on this.

This is my setup now

2005 touring
new pass side outter tie rod
stock contis on factory wheels
 

·
Registered
Joined
·
3,692 Posts
Stock Contis maybe? Things got a lot better for me when I got rid of
those. I'm riding on Goodyear now. The car feels much more stable
but there is still a very, very slight vibration around 80. I've gotten
it down some by having the shop I bought the tires rebalance it.

I'd be suspicious given you've already had tie rods replaced once.

Doe the car feel loose at high speeds?
 

·
Registered
Joined
·
1,305 Posts
Discussion Starter #3
Its weird, I get the vibration from like 78 up to 85 but if I put it past 100 its very smooth.


I wonder why 80 is the magical number.
 

·
Premium Member
Joined
·
4,708 Posts
Balance the front tires.
 

·
Registered
Joined
·
1,305 Posts
Discussion Starter #5
That was my next option. I figured if the front end was tight at all other speeds then I may have thrown a wheel weight. I guess the real test will be in a week when Im bagged and I have my 22s on.
 

·
Registered
Joined
·
3,692 Posts
If you don't have a problem with your 22s on you'll know right away that
your stock setup had a balance problem.
 

·
Registered
Joined
·
1,305 Posts
Discussion Starter #7
definately the wheels were out of balance. 22s are smooth as glass up to 100 and beyond.
 
1 - 8 of 8 Posts
Top