Chrysler 300C & SRT8 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Just like 9/10 of the other 300C owners out there, I frequently do a check-up on all the functions of my car. Whether it's the engine, convenience features, etc. Anyway, as I was sitting in my backseat, I flipped on the right-heated seat button, and after about a minute or so, the orange light started to blink intermittently off,on,off,on.

None of the other seats do this. Anybody else ever experience this!?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Well, I've somewhat pinpointed something. It works just fine when it's the only backseat switch that's active, but if I turn on the other one, it starts to blink. Here's a video of it.

 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
AH! Found the problem. Feel rather dumb for this one, but when I was checking it out, it only does it when the ignition is in the "ON" position, but the engine not running. When the engine is running, both seats work functionally. Like I said, I feel rather dumb, but with gas prices the way they are, didn't want to start the engine if I didn't have too!! :p
 

·
Registered
Joined
·
1,048 Posts
Hmmm just installed mine but do not feel heat, but I also did not turn the car on LOL,will give it a try 2morow
 

·
Registered
Joined
·
397 Posts
wow the 08 has heated rear seat i never knew this ahah wow nice anyone know if i can install the 08 leather in my 05 and have heated seats ahahah
 

·
Registered
Joined
·
1,048 Posts
Hi
You can get them on Ebay, it easy to remove the rear seats and install on your kitchen table, I ran my power source to my cig lighter, b careful when you put back the center console not to smash the wire, there may be another source?
 

·
Registered
Joined
·
49 Posts
My car was running and mine blinks..the rear seat lights turn on both then bottom shuts off and top one blinks? Not like the front..any ideas?
 
Joined
·
14 Posts
My car was running and mine blinks..the rear seat lights turn on both then bottom shuts off and top one blinks? Not like the front..any ideas?
This is an old thread but I have the same issue with my '07 300c with rear seat warmers. I bought it new and the rears have not been working for a few years now with the same symptoms. Fronts work fine. Reseated the module connector, pulled back-bottom seat and measured ohms on elements. Fuse 7 is good. Swapped relays around. Is the module under the passenger seat for both front and rear heaters? Can't imagine. Pulled it part and see no damage.
Also, impressive as rear seat warmers are, is auto-dimming headlights and power adjustable gas and brake pedals common? Both nice features. With AWD this thing just goes. It doesn't care where you are. I was, however disappointed to not find a cabin filter under the passenger wiper cubby under the hood. Thanks!
 
1 - 10 of 10 Posts
Top