Chrysler 300C & SRT8 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
I know this may be the wrong section but I am stranded at work right now and have no solution.

Anybody have this happen to them? This is like the 5th time it has happened to me. I accidentally turn on the alarm before closing the door and the alarm triggers. I try to disarm it with the key, then try and turn the car on and put it in drive, but nothing works. It just blazes, while I have to get tools and disconnect the battery. I have been to the dealer twice on this and they say they don't know the problem. This time though, I cannot get the damn thing to turn off and stranded at work. Any ideas?

I haven't tried the negative terminal yet...maybe that will disarm it, or maybe the fuse.
 

·
Registered
Joined
·
1,108 Posts
My dads 90 Chrysler had similar issues with the alarm. Check for corrosion on the positive battery terminal. Dont know what it is about his car but it likes eating the battery. Clean the terminals and connections and you should be good to go if its the same reason. Let me know it it works.
 

·
Administrator
Joined
·
23,436 Posts
I've seen that in a Jeep before where the alarm wouldn't shut off. Turned out it was the battery that was bad. I agree with bund to check the terminals first then have your battery tested later on.

Bernie
 

·
Registered
Joined
·
1,108 Posts
The thing with my dads car is that it did that to 2 batterys now, one battery was perfectly fine till it was installed into my dads car (battery donated by another chrylser we had with the exact same battery). I think with my dads car theres some underlying cause. But yes clean terminals and once reconnected listen to the terminal carefully (listen for a sizzle sound), if you hear it then disconnect and reconnect till you dont hear it.
 
1 - 4 of 4 Posts
Top