Chrysler 300C & SRT8 Forums banner
1 - 6 of 6 Posts

Registered
2007 Chrysler 300c
Joined
2 Posts
Discussion Starter · #1 ·
What's up guys? I have a 2007 Chrysler 300 C and I recently installed a cheap double din indash. I got picture but no sound so I did the amp bypass but I want to have my factory amp so i ordered the rp4-ch11 harness. It is supposed to let me retain my factory amplifier along with my steering wheel controls however after hooking it up I still have picture but no sound. HELP ME馃槶
 

Registered
Joined
225 Posts
Did you use all adapters? Or did you cut any wiring?

Sent from my SM-N960U using Tapatalk
 

Registered
Joined
225 Posts
I believe I have seen a factory amp bypass on Crutchfield. Mine was bypassed when I got it, but some jackwad cut the wires. So my dash speakers aren't hooked up, neither are the tweeters.
Was the head unit new or used?

Sent from my SM-N960U using Tapatalk
 

Registered
Joined
2 Posts
What's up guys? I have a 2007 Chrysler 300 C and I recently installed a cheap double din indash. I got picture but no sound so I did the amp bypass but I want to have my factory amp so i ordered the rp4-ch11 harness. It is supposed to let me retain my factory amplifier along with my steering wheel controls however after hooking it up I still have picture but no sound. HELP ME馃槶
Depending on your options (NAV, Rear video) one of the PAC adapters should work fine. I used one on my 2005 Magnum. https://catalog.pac-audio.com/?fc=m...make=10&model=300&year=2399&trim=2434&submit=
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top