Chrysler 300C & SRT8 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Hey guys,

My 05 300 Limited has been acting funny the last day or so. Yesterday the radio started to turn off by itself, then all the needles on the dials(speedometer etc.) stopped working and went to off positions. Also traction control was acting funny and the ESP/BAS and airbag signs were going on and off intermittently.

Now the car wont turn on and all the lights on the dashboard are on. (ESP/BAS, Airbag, Brake, etc.). When I tried to turn it on, It didn't do anything at all, no sounds at all. I called the local 5-star dealer and they said unhook the battery for 31 mins, and I did that and the same things are happening.

Im gonna try to jump it as soon as my roomate gets back. Any ideas guys before I get it towed out to the dealer?

~Mo
 

·
Banned
Joined
·
5,754 Posts
check the battery ground in the trunk,

also check all of the fuses, these cars are known to come from the factory with the fuses loose, push them all down tight, in the trunk fuse block and in the one under the hood..

there have been a lot of owners that have had the ground cable on the battery vibrate loose..
 

·
Registered
Joined
·
40 Posts
I have the same problem; while driving suddenly the speedometer and rpm are going down to 0 and all dashboard lights go on. They go off after 10 seconds but the ESP lights stay on.
However, the engine still runs and I can continue driving 'normally'.
This happened already a couple of times. After reading this thread I will go and check all fuses and the battery cable.

I'll keep you posted if it will happen again.
 
1 - 5 of 5 Posts
Top