Chrysler 300C & SRT8 Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
1,369 Posts
Discussion Starter #1
My wife just came home after fueling up at the same gas station we always use and the malfuction light came on and its staying on.I have a 05 Limited, just like to know if anybody had this light stay on,and what was the problem or did it reset it self.Thanks
 

·
Registered
Joined
·
566 Posts
Not 100% sure, but i think i remember someone saying that if the gas cap isn't tight enough that it could trigger the it. It was a while ago, I don't really remember, it wont hurt to try it though.
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter #3
Thanks that was the first thing i did after i read the manual,its still on maybe it has reset.
 

·
Registered
Joined
·
566 Posts
Yeah i would pull fuse 11 and reset everything, if it comes back on then you might have a bigger problem...
 

·
Registered
Joined
·
377 Posts
DONT pull fuse 11 yet!! you should see what the codes are first. If you wipe it all out then their lost. I think the procedure is get inside vehicle close doors turn key to on then off 3 times arriving back at on and then in your evic screen it will list the codes one by one. When it is finished it will say done. Then you can do a search on here and find what that code(s) mean.
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter #9
THE only thing that it is showing is system ok but the light is still on,dont know if i am doing something wrong because no codes are coming up
 

·
Premium Member
Joined
·
4,708 Posts
Just continue to drive it normally. After 5 or 6 normal trips the CEL will go off by itself.
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter #11
Thanks DESIREE hope you are right,so if its showing no codes and saying system ok on the screen means its just got to reset it self?
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter #12
Well took a ride to the store and light still on,hoping tommorow with a little more driving it sets.
 

·
Premium Member
Joined
·
10,829 Posts
I think your car will be just fine. When you checked the gas cap after the malfunction, did you actually take it off, put it back on, and then turn it so that you heard at least 5-6 clicks?

As you put more mileage on the car, the light will eventually go out when you least expect it!

bruno
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter #15
Thanks Bruno I was getting a little nervice because I just did all these mods this spring and I really dont want to drop more money right now into the car.Thanks again and I will keep you posted.
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter #16 (Edited)
Well finally got the code to display and it says:
P0406
EXHAUST GAS RECIRCULATION SENSOR A CIRCUIT HIGH
I am hoping it was just a bad gas that was put into the car,did anybody else have this code.
 

·
Registered
Joined
·
1,108 Posts
The same thing happened to me in my impala. Just take the gas cap off and put it back on properly. That will solve the problem. I always turn my cap now a bunch of times to make sure its on.
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter #18
Thanks for all the help guys!I give you an up date in the next couple days if light goes out.
 

·
Registered
Joined
·
1,108 Posts
you may have to clear the code for the light to go out.
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter #20
Thanks again everybody but today after I left the gym and started the car up no more malfunction light on ,man was I relieved not to see that light on.Thanks again!
 
1 - 20 of 22 Posts
Top