Chrysler 300C & SRT8 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
338 Posts
Discussion Starter #1
While Driving Usually For More Than An Hour The Defrost And / Or Heater Starts Blowing Cool Air On The Drivers Side Only,
As Well The Instrument Panel (center Pod) Gets Hot To The Touch.
Has Anyone Else Had This Problem?
Or Any Ideas?
Thank You
 

·
Registered
Joined
·
1,014 Posts
Same here.
Usually it seems that the auto temp is adjusting. I make sure that the passenger's vents are not toward the driver's side and turn both guages to the same temp.

As for the instrument panel, when I go in for my next oil change I was going to bring it up and yes it get's hot.
 

·
Registered
Joined
·
338 Posts
Discussion Starter #3
Thank You And My 300 Is At The Dealer Now; If They Find The Problem I Will Be Sure To Share
 

·
Registered
Joined
·
131 Posts
I have the same problem also. I had the same problem with a Jeep I owned previously. There is a sensor in the center of the instrument panel that is supposed to guage infrared heat of the front passengers.

It was my theory with the Jeep that it started to see the heat from the instrument panel and adjust the heat down even though I still wanted up. It seems the 300C has the same attitude. Once again just a theory.
 

·
Premium Member
Joined
·
2,073 Posts
Wow, I feel better now. I've noticed this the last few times I've gone on drives over 30-45 minutes and thought I was going crazy. I had to crank the heat up to the red dot to make it get warm again. Please keep us updated.

I swear, this board is the absolute greatest!
 

·
Registered
Joined
·
338 Posts
Discussion Starter #7
Thanks For The Replies
I Should Be Hearing From The Dealer Today
 
1 - 7 of 7 Posts
Top