Chrysler 300C & SRT8 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
I think I blew a head gasket but i'm not 100% sure. I'm taking it to a mechanic this weekend.

But I'm going up a hill and I hear a clacking noise so I switch lanes to get off at the upcoming exit. As soon as I go to get off the exit, My car cuts off, oil light come on and it start smoking under the hood.

The car temp gauge on the dash is in the normal range but there was little coolant in the resevoir.

I get it towed to my house and the next day I attempt to start it to see of it would start and it cranked but the engine wouldn't do it's part. I don't know if that has something to do with the compression or something? My brother think it may be a blown head gasket.

It's a 2.7L base 300. If anyone have any clue or idea what this may be then fell free to post.


Thanks
 

·
Registered
Joined
·
149 Posts
The fact that the oil light came on is likely not good. Have you checked the oil? Sounds like you may have broken a piston rod. I hate to say that, but that's what it sounds like. When you cranked it in your driveway, did you again hear a loud clanking noise? If so, not good. Tough to diagnose from here, but keep us posted. And best of luck. I really hope I'm wrong!
 

·
Registered
Joined
·
149 Posts
Have you determined what happened to your engine? I'm curious.
 

·
Premium Member
Joined
·
4,708 Posts
I am not into the wee-6 engines, but I seem to remember reading somewhere that there were valvetrain issues. Maybe someone can chime in on the matter?
 
1 - 6 of 6 Posts
Top