Chrysler 300C & SRT8 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I have a 2010 300C and I recently installed an Airraid CAI and in the process I broke the IAT that was already installed. I ran to the parts store and grabbed a replacement (Mopar PN 56028364AA) (I also tried Mopar PN 4606487AB, it doesn't fit). I plugged it in and didn't have any codes or lights but when checking with my Predator 2 the IAT is constantly -40degF, I swapped that one out and got another new one and still I'm having the same issues. Is there something I'm missing?
 

·
Registered
Joined
·
707 Posts
If the -40* is accurate, you should be getting a Malfunction Indicator Light (MIL). I have an adjustable IAT on my 05 Hemi LX and if I set it to an "unreasonable" setting or move the setting too quickly, the light comes on immediately. I use my DashHawk to monitor the IAT. The PCM pulls readings from other sensors, such as the ambient air temperature sensor, and it rationalizes about what range it should be at that time. I usually run mine at about 40*F less than ambient and that seems to work the best.
 
  • Like
Reactions: SCMRoman

·
Registered
Joined
·
26 Posts
Discussion Starter #3
If the -40* is accurate, you should be getting a Malfunction Indicator Light (MIL). I have an adjustable IAT on my 05 Hemi LX and if I set it to an "unreasonable" setting or move the setting too quickly, the light comes on immediately. I use my DashHawk to monitor the IAT. The PCM pulls readings from other sensors, such as the ambient air temperature sensor, and it rationalizes about what range it should be at that time. I usually run mine at about 40*F less than ambient and that seems to work the best.
Is it possible then that the Predator 2 isn't getting the correct reading or that I'm checking the wrong parameter with it? I assumed if I clicked IAT it would be correct but could it be labeled under air charge temp (ACT)? I've tried 3 different sensors from 3 different brands now, the car seems to be running fine.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
If the -40* is accurate, you should be getting a Malfunction Indicator Light (MIL). I have an adjustable IAT on my 05 Hemi LX and if I set it to an "unreasonable" setting or move the setting too quickly, the light comes on immediately. I use my DashHawk to monitor the IAT. The PCM pulls readings from other sensors, such as the ambient air temperature sensor, and it rationalizes about what range it should be at that time. I usually run mine at about 40*F less than ambient and that seems to work the best.
Also where'd you get the adjustable IAT? Would you say it's a worthwhile purchase? I have my car custom tuned from Diablotoona, and the CAI but there's defintely more planned for the future.
 

·
Registered
Joined
·
707 Posts
I am not familiar with the Predator readouts, so I can't comment on that. I built my own adjustable IAT years ago when some forum members were cussing and discussing the benefits or not of the so called, Power Wire which is a fixed resistor that lowers the IAT at all times by a certain amount. The IAT varies with the ambient temperature, as does mine.

As far as whether it's worth it or not, I'd say don't waste your time because, if there is a difference, it's so small you won't be able to tell the difference. I just left mine on all these years because it's not causing any problems either. The only real difference I notice on my DashHawk is that it'll allow for a little more timing with the cooler temperature input from the IAT.....again, not enough to make a significant difference. I wll say though, that with my modded 5.7 (see signature) I do routinely get 27-30 mpg on the highway, so some of the mods (cumulatively) have made a pretty good difference. If you want to know a little more about the stuff I've done, let me know.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
Man I have a lot of questions about modifying the 5.7 Hemis. This is my first one and I'm just trying to soak up as much information as possible and be a little more well informed before I get to into the build. Trying to find good resources for information, good companies for aftermarket parts, cross compatibility for year ranges and 6.1/6.4 Hemis. I'm a little lost at the moment, they're definitely a lot different than the 5.2 in my 97 Ram.
 

·
Registered
Joined
·
707 Posts
You may want to start a separate thread on that subject so we're not jacking this one. Other memberss will see it too and you'll be able to get lots of neat ideas, depending on your ultimate goals.
 
  • Like
Reactions: SCMRoman
1 - 7 of 7 Posts
Top