Chrysler 300C & SRT8 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
666 Posts
Discussion Starter #1
used my fob to unlock the car this moring, headlights came on dash and radio on, but no center consoul, door
or overhead dome lights, blown fuse??

any help/tips would be great

2005 300c 5.7 28k
 

·
Administrator
Joined
·
23,437 Posts
I guess the most obvious thing to do is check all fuses for proper seating and look for a blown fuse as well.

I just finished going through the service manual and there doesn't seem to be one for the those lights specifically. Is your clock working? If you could find out exactly what's working and not working maybe it would be easier to find out the fuse number, it that's even what it is. It's a good starting point though.

Bernie
 

·
Administrator
Joined
·
23,437 Posts
I wish it was like the old days where everything was listed, but it doesn't. I did find most of the accessory things seem to be located in the Rear power Distribution Center though. At least it might narrow it down a little and you'd have less fuses to check.

Bernie
 

·
Administrator
Joined
·
23,437 Posts
looks like this is a common problem, found in the problem tread, looks like fuse 5 is blown,
Hey, how about keeping us updated on this?

All the manual says about #5 (Front - 25 amp, clear) is Headlight Washer (if equiped) and #5 (Rear - 30 amp, pink) is Heated Seat/Steering Column.

Bernie
 

·
Administrator
Joined
·
23,437 Posts
I just read MoparPat's thread, and it's probably the one you referred to. Seems like disconnecting the battery for 15 minutes is the answer to prevent it from happening again.

Bernie
 
1 - 10 of 10 Posts
Top