Chrysler 300C & SRT8 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
My 08 limited with the auto HVAC system has developed a fogging problem since it got cold here in New England. It will fog up the inside of all interior windows. After switching to the defrost mode it will not start to defog them right away and never completely defogs them. I took my other vehicle on a long trip recently because it is so bad that I am not getting enough visibility to feel safe. First thing I noticed was the AC compressor was not running during defrost mode. I had the system fixed at a mechanic (low freon). It now runs constantly during defrost mode. I have cleaned the windows, there's no puddles of water on the floor. The fog is not extra slippery as if it were coolant. I also checked the air intake to ensure it was clear of debris.

Anyone have/had this issue? How was it fixed?

Thanks,
Dave
 

·
Registered
Joined
·
1,140 Posts
is it actually going in the defrost mode put your hand on the dash defrost vents and see how much airflow is coming out and check the temperature it should be quite warm and lots of air flow.
 

·
Registered
Joined
·
16 Posts
Im having the same problem with my '06. I've been cracking the rear windows or moonroof, it helps a lot, and the climate control has no problem keeping up. I think its just the weather, im in the Pocono Mts in PA and it was 0 last night, so I had frozen fog. If you find out anything I'd like to know too.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
I've got warm air and lots of it coming out the dash/windshield vents and the upper fixed vents near the front doors. I checked all of the other vents and there's no air coming out of them. With all the snow we've had here and my lack of a garage is it possible that the snow is melting and falling into the cabin air intake? I don't have a filter on mine and I don't think I'm supposed to. Does anyone know if you can put a filter on a limited? I think the C's have them.

Dave
 

·
Registered
Joined
·
1,140 Posts
DAVE you said you have warm air what is warm it should almost 80 some degrees coming out (est) i would check to see if you have an ice clog on the fresh air intake. i am glad it only snows here once in a while.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
I found the problem (sort of). There's a giant wet spot of carpet underneath the driver's floor mat just in front of the seat. I'm must be getting water inside the car somehow. I had my mechanic pull the carpet up and dry it all out. Then he poured water on the car to try and spot the leak: nothing found. Has anyone had a leak like this? I'm going to have to watch and wait for it to leak again.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
I do have a moon roof. It was checked and it is not leaking. Thanks for the TSB, but it says it will only apply to 06-07 models. I have an 08. But I will dig around and call my local dealer about any other TSB's for my model year. Otherwise I'm going to wait until it snows/rains again and see if I have the problem again. Since the car has been dried out there has been no fogging issues.

Dave
 
1 - 9 of 9 Posts
Top