Chrysler 300C & SRT8 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter · #1 ·
1. When my car is in neutral or in park and I rev the engine it only revs to like 4000 RPM's. Is this happening to anybody else? :confused:

2. When I fill up the tank with gas it only goes just above the 3/4 point
on the gauge. Is this happening to anybody else? :confused:

3. When I set the speedometer to show up digitally it goes 5 miles an hour faster than the normal speedometer. Is this happening to anybody else? :confused:
 

·
Registered
Joined
·
82 Posts
I read another post on this site about this problem...

You have to go to the dealership and get it fixed.

I guess they had some electronic circuitry patch they have to
put on for those of you that have been experiencing this problem.

I hear it's a quick fix.
 

·
Registered
Joined
·
85 Posts
1. Unkown. I don't do that to my car while in park or neutral.

2. There is a computer problem in some 300s, not mine, that caused the fuel guage to read off like that, they will fix it at the dealer by reflashing the computer, or something. It's an easy fix.

3. I didn't even know you could set it up that way, I will figure out how and post my results.
 

·
Registered
Joined
·
436 Posts
Let me tell you what I think...

I feel the revving the car and it only revving up to 4 grand is the computer making sure you don't over rev the car. It does it in my 300C.

The gas tank thing happened to me early on when I first got the car back in March of 04', keep forcing gas into it and it will soon go up to over the full fuel mark.

The speedo problem might be a software thing, you might want to take that in, while your there you can ask them about the other two problems even though I think I nailed the other two problems for you. :)
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #7 ·
Thanks I tried to do a search but was using the wrong words for the search. I will contact my dealer asap.
 

·
Registered
Joined
·
323 Posts
No explanation required, I have to used the search before and not found what I was looking for. Sometimes people would explain a problem with different keywords, we are here to help each other out.
 

·
Premium Member
Joined
·
1,409 Posts
Nothing is wrong with you vehicles, DCX designed the car this way it is called a REV limiter as BBH said, and it is there to protect the engine from people who would sit and rev the engine in park or neutral as this can cause damage to any engine especially ours with the MDS, so dont call your dealer it is by design.
 

·
Premium Member
Joined
·
1,409 Posts
As per the gas hand I cant speculate maybe you need to see your dealer. The speedos should be accurate with each other. If you have the current software upgrade which is 3.61 with a date of 7/24/04(it will appear at the beginning of the program when you go into the cluster, if not arrow up or down until you see the page) if yours reads something else you need to have it reflashed, then if you have aftermarket wheels and tires your tranny may have to be recalibrated, if you have the OEM wheels and tires then I dont know why its this way. Take it to a dealer.
 

·
Registered
Joined
·
73 Posts
shanemcse said:
1. When my car is in neutral or in park and I rev the engine it only revs to like 4000 RPM's. Is this happening to anybody else? :confused:

2. When I fill up the tank with gas it only goes just above the 3/4 point
on the gauge. Is this happening to anybody else? :confused:

3. When I set the speedometer to show up digitally it goes 5 miles an hour faster than the normal speedometer. Is this happening to anybody else? :confused:
(1) wierd
(2) Just took my wife's C in last week for this. Reflash at the dealer fixes the cluster.
(3) see answer two. same problem cluster needs reflash.
 
1 - 12 of 12 Posts
Top