Chrysler 300C & SRT8 Forums banner

1 - 20 of 29 Posts

·
Registered
Joined
·
332 Posts
Discussion Starter · #1 · (Edited)
Jet chip install (HORRIBLE AND NOT EASY AND AFTER INSTALL ITS GO TIME!!!!!!) NICECHIP

READ LAST POST IF U WOULD LIKE TO SEE THE PERFORMANCE
IMPROVEMENTS. :D :D

NEVER MIND THE PICS I FIXED THE INSTALL. CLEANLY IN TO THE BAY.

READ LAST POST. 400 viewers and no posts. HMMM



DO NOT, I MEAN DO NOT GET THIS CHIP IF U HAVE NEWER 300C or MAGNUM.
If ur car is made after july 04, this is one hell of a install and not a whole lot worth it for 10-20 hp it provides. I am including pictures, i destroyed some firewall or some padding i think in the car it was one frustrating install PIC#1 and PIC#2. OK
I finnally did not give and thought of another solution. I ran the 3 ECM cables to the engine side. Please look at PIC#4 for this one and then i rested the ecm on top of the engine cover PIC#3. IS THIS SAFE, THE HOOD CLOSES COMPLETELY. Will the engine temp burn my ECU away. NEED HELP Please respond right away i need some help fast. I cant do a 0-60 without the safety of the ECU, Plz let me know.
 

Attachments

·
Registered
Joined
·
528 Posts
Free Advice!

1st: Hang head low.
2nd: Call tow company.
3rd: Call dealer.
4th: Empty wallet.
5th: Enjoy post-Easter festivities: CAR REBORN! :p
 

·
Registered
Joined
·
332 Posts
Discussion Starter · #3 ·
Car turns on.
Nothing damaged it can all be put back the way it was with out the chip
warranty voided dont care getting a SC on it any way.
car will run from the looks of it.


I dont give up do i. 2 hours of time, this is where i ended up
 

·
Registered
Joined
·
332 Posts
Discussion Starter · #4 ·
Northern Rider and the Some member that know about this i could really use your help here. Plz i dont want u to flame me just a suggestion is helpful and if u got any smart(funny) comments plz leave them out. I am helping the guys that want this chip, i am not so fond of this either. I am getting an sc anyway.
 

·
Registered
Joined
·
332 Posts
Discussion Starter · #6 · (Edited)
JustForFun said:
Whats an SC?

No offense, but your first post had me crackin' up!

Good Luck!

JFF:D
I could tottaly understand, but can we all let this go under our radars and help me out i can even attach everything back, the firewall was not removed only the padding(INSULATION i can tell because i am allergic to it) on it.
SC(SUPER CHARGER).

PS: TURNED the car on, will leave it on but the ECM is NOT resting on the engine cover. I want to test how HOT the engine cover gets.
 

·
Registered
Joined
·
59 Posts
300CAWD
I had a heck of a time too. I used a big pry bar and pushed back on the rubber moulding. It finally went in. I plugged everything in first...then used the bar to push the plastic back far enough.
I hope it helps...
 

·
Registered
Joined
·
73 Posts
BBC said:
300CAWD
I had a heck of a time too. I used a big pry bar and pushed back on the rubber moulding. It finally went in. I plugged everything in first...then used the bar to push the plastic back far enough.
I hope it helps...
Ditto. Also, install the module to the disconnected ECU on a flat firm surface and press firmly and evenly on the module so that it properly seats on the ECU.
 

·
Registered
Joined
·
332 Posts
Discussion Starter · #9 ·
BBC said:
300CAWD
I had a heck of a time too. I used a big pry bar and pushed back on the rubber moulding. It finally went in. I plugged everything in first...then used the bar to push the plastic back far enough.
I hope it helps...
Very true,

That could be done. There is a lot of empty space behind that padding, why the hell did dcx even put this thing(padding) here anyway. OK padding can be pushed back but what about the, small bar that sticks the one that blocks the jetchip from going in to that slot in the first place.
 

·
Registered
Joined
·
59 Posts
You have the plugs facing the firewall right?
 

·
BLOODY ADMENSTRUATOR
Joined
·
7,554 Posts
300CAWD said:
Northern Rider and the Some member that know about this i could really use your help here. Plz i dont want u to flame me just a suggestion is helpful and if u got any smart(funny) comments plz leave them out. I am helping the guys that want this chip, i am not so fond of this either. I am getting an sc anyway.
I hear your call for help. 300CAWD, but my car and I are separated by about 3000 miles. I can't give you any guidance. Don't do anything drastic. There are lot's of good folks that will help you through this.
 

·
Registered
Joined
·
59 Posts
did it go in? I know how much of a pain it was!
 

·
Registered
Joined
·
332 Posts
Discussion Starter · #13 ·
DONE,

BUT A PROBLEM,

Check Engine light

and

The plastic stuff it cracked while using the crowbar. Anything major here.

IF THIS IS A FAILED INSTALL I WILL TAKE IT TO SERVICE FIRST THING IN THE MORNING.
 

·
Registered
Joined
·
332 Posts
Discussion Starter · #15 · (Edited)
JET CHIP RESULTS. Saved almost .2 secs of my 0-60 times.

HOLY MOLY(BATMAN),
AMAZING.

The car ran an amazing 5.6 secs consequentily for 3 runs straight and the transmission slow shift(45mph-50mph shift) is almost gone.


SPECS:
car: chrysler 300c awd hemi
chip: Jetchip Stage 1
The oil change is at 2500 miles got the oil change at 2k miles on the car now the car is at 4.5k miles.
The fuel tank is under the quarter mark so i would say about 5 gallons in the tank.
The gear was set to 2nd, esp on it ran 5.63 and with esp off it ran 5.6 and 5.59. Amazing chip unbelivable.


If i get an oil change, full tank of gas, and wheel alignment(ok it has nothing to do with improving 0-60 times). I would be sure that 0-60 times will be under 5.55 constantly. With out the chip my averages were 5.75 to 5.85. With my best run at 5.7(NON CHIPPED) and there is a video in this forum to prove that as well.

I WOULD LIKE TO THANK 300C4ME AND BBC FOR MAKING THIS POSSIBLE.

PS: The car is injured due to the install, the plastic cover(i think its called the firewall) behind the ECU has been broken and some of the insulation(this stuff is allergic) has been removed as well off the plastic cover.

VIDEO COMING VERY SOON. I THINK I NEED START CHARGING SOME CLAMS FOR THIS VIDEO. 3 HOURS OF WORK AND ITS ALL WORTH IT.
 

·
Registered
Joined
·
666 Posts
If you still have the light, don't take it in just yet. The PCM has discovered something different (the chip) and is alerting you. If it doesn't go out in a couple days (at least 3 good cycles) then you may have to take it in. Most MIL's take 3 good cycles and they'll go off by themselves, but the PCM still has a record of DTC's stored until they're cleared at the dealer.
 

·
Registered
Joined
·
332 Posts
Discussion Starter · #17 ·
magnuman said:
If you still have the light, don't take it in just yet. The PCM has discovered something different (the chip) and is alerting you. If it doesn't go out in a couple days (at least 3 good cycles) then you may have to take it in. Most MIL's take 3 good cycles and they'll go off by themselves, but the PCM still has a record of DTC's stored until they're cleared at the dealer.
MINE WENT AWAY,

THANKS MAGNUMNAN.

I am so happy with this chip, with just 20 hp it feels go good.
 

·
Registered
Joined
·
73 Posts
Glad it all worked out! :) The installation is not for the faint at heart is it. However, the performance gain is worth it in IMHO.
 

·
Registered
Joined
·
72 Posts
will i have this problem?

is everyones install like this am i gonna have the same prob on mine? its a rear wheel drive hemi is the chip worth all that work???
 

·
Registered
Joined
·
17 Posts
i have a stage 2 jetchip and while it was a lil tricky to install it took only 20 minutes or so..nothing was broken or damaged...im glad someone finally has proven that the chip makes a difference, as I have been pleased with it :)
 
1 - 20 of 29 Posts
Top