Chrysler 300C & SRT8 Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Hello guys

I have a 2010 300c SRT8, and I'm having a knock or clunk noise from the rear when:
1. I'm driving 30 - 50 miles an hour and I gently release the gas pedal. Sometimes when I gently press the gas pedal again. Of course if I press it hard I won't hear this sound
2. when I put the car in the manual mode and slow down so the car by itself downshift from 2nd to 1st gear.

(don't really no the difference between the knock & clunk noise)

The car is still under warranty to I took it to the dealer several times and at the first time they said it needs to be programmed.... so they installed the updates.... but the sound was still there..... so I took it to the dealer again.... and they said some parts of the rear susbension needs lubrication ..... so they lubricate something but the sound was still there ..... I drove test the car and found the sound still there, so I told them about and they said this is normal and we can't do anything about it .... I believed them and took the car ..... after one month I drove my friends 2006 300c SRT8 and this sound was not there at all.... I did the same tests and nothing was there..... so I took my car to the dealer again ..... and they test drove it and the guy who tested it said it's likely the differential bushings ..... so they looked at the bushings but found them good as they say..... Now there trying to convene me this is normal

previously I thought this is the differential (because it was whining & clicking or clunking or nocking) but they have changed the differential and the whining is gone but noise is still there. So it's not the differential. could it be the gear box. could it be related to the suspension or bushings.

I wish any one who had this problem fixed could help me. I hear this is a common problem.
 

·
Registered
Joined
·
16 Posts
i have a similar problem. i hate hearing that noise. i think its the transmission though
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
Thank you guys

I asked the dealer to check the items you suggested.

Any other suggestions?
Any one with previous experience?
 

·
Premium Member
Joined
·
4,252 Posts
Most likely a motor mount if every other item mentioned was PROPERLY checked out.

look directly at the mounts with the cover off the underside of the car. If a motor mount is bad it will spew yellow fluid all over the place, very hard to miss.

Could also be a trans crossmember mount as well.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #6 ·
Thank Stevesrt8

I'll have transmission mount checked as well. I would not think it is related to the motor mount since the noise comes from the rear.

I see you agree that's not normal. It's strange the dealer tries to convince me otherwise.

You're help is appreciated. I will keep you informed once find the problem & fix it.
 

·
Premium Member
Joined
·
4,252 Posts
I broke my drivers side mount at the strip and never even knew it.

A strange thunk from behind my seat started me looking and I figured it out after a LOT of looking.

May not be obvious, but it is a possibility.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #8 ·
I broke my drivers side mount at the strip and never even knew it.

A strange thunk from behind my seat started me looking and I figured it out after a LOT of looking.

May not be obvious, but it is a possibility.

it's good you found it ........ what exactly did you break the transmission mount?
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #9 · (Edited)
I told the dealer about all your suggestions ..... and after insisting they promised to examine the the possibilities ..... they told they found the transmission mount and differential mount damaged and they order these items ....... I will let know how it goes .... I hope they figured out the problem
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #10 ·
well guys I promised to let you know when I figure out about the problem, but unfortuantly I sold the car before the trans and diff mounts' replacement and cannot confirm whether or not the knock was caused by these parts.

I bought 2010 Challenger SRT8 with 19,000 km on it .... I get the same knock but not as strong as it was on 300c... maybe this is too common ... or maybe it's normal.
 
1 - 10 of 10 Posts
Top