Chrysler 300C & SRT8 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi to all. I have a 2006 Chrysler 300C SRT8 With 90,000 miles that I really love but I’m to my wits end with it and thinking about getting rid of it. I’m having communication problems with the vehicle. For starters when I plug in the car to a computer to show me all the analytics on the car I am getting full power to all modules and it says everything is working like a should with no problems. But it does say that I’m getting a miss communication with the hvac system.
The problem I’m having is My hvac climate controls won’t turn on, my Parkin assist won’t turn on the passerger air bag light is on and it says for me to check the tmp on all tires but they’re all good. I have bought all new fuses and relays for the front and back fuse boxes, I have checked all the modules and have hard reset the ecu and pcm several time but nothing works. I’ve also changed the 2 diodes in the rear fuse box. Has anybody had this problem before? Please help.
 

·
Registered
Joined
·
383 Posts
Hi to all. I have a 2006 Chrysler 300C SRT8 With 90,000 miles that I really love but Iâ€m to my wits end with it and thinking about getting rid of it. Iâ€m having communication problems with the vehicle. For starters when I plug in the car to a computer to show me all the analytics on the car I am getting full power to all modules and it says everything is working like a should with no problems. But it does say that Iâ€m getting a miss communication with the hvac system.

The problem Iâ€m having is My hvac climate controls wonâ€t turn on, my Parkin assist wonâ€t turn on the passerger air bag light is on and it says for me to check the tmp on all tires but theyâ€re all good. I have bought all new fuses and relays for the front and back fuse boxes, I have checked all the modules and have hard reset the ecu and pcm several time but nothing works. Iâ€ve also changed the 2 diodes in the rear fuse box. Has anybody had this problem before? Please help.


I just had a bunch of issues somewhat like that albeit with different systems...some things worked and some didn’t. It ended up being my PCM.
 

·
Registered
Joined
·
3 Posts
Hey guys i have the exact same problem and was told that the bcm should be replaced.. should i replace the bcm or the pcm??
 
1 - 5 of 5 Posts
Top