Chrysler 300C & SRT8 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
293 Posts
Discussion Starter #1
I keep getting a code on my Diablo for a misfire. Do you think it's a worn spark plug? I have 16000 miles on the car but the motor has been worked on. PPP stage2, headers, etc.....
Anyone get anything like this?
Thanks
 

·
Premium Member
Joined
·
1,117 Posts
I keep getting a code on my Diablo for a misfire. Do you think it's a worn spark plug? I have 16000 miles on the car but the motor has been worked on. PPP stage2, headers, etc.....
Anyone get anything like this?
Thanks
Do you have the PPP CMR tune? If your running the CMR tune your probably OK. If you are running one of the Diablo custom tunes you might have a problem? With heads, headers and a custom tune you may be running lean! Use the data log feature and monitor your knock retard and knock sensor voltage as soon as you can. If you are getting a voltage reading over 1 you should probably get a CMR tune. If you are getting a voltage reading over 2 you should think about parking it until you get the knock issue figured out. Bad gas could also cause high knock voltage.

If it is not the tune it may be fouled plugs or any number of other things. I'd start with by checking your plugs. You are probably getting a cylinder number along with that code so that would be the plugs to start with. If it's not your plugs or tune it might simply be bad gas. Try a different gas station and some high octane fuel. This would help both the overly aggressive tune and the bad gas scenarios.

If you still don't have any luck the next stop would probably be the fuel injectors.

Hope that helps. Good luck.
 
1 - 2 of 2 Posts
Top