Chrysler 300C & SRT8 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Yes I have a 05 Chrysler 300c Hemi and I replaced the PCM in throttle body and it cranks over but no start prior to this it ran so can anybody help me please
 

·
Registered
Joined
·
581 Posts
So you replaced the PCM, correct?

Did you or the seller program your car's VIN into the replacement unit? Or did you just take a used PCM from another 300, plug it into your car and expect it to start?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
No i odered one it was plug and play they programed it to the vin
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
P2101 p0685 p2101 p0633 p2122 p2111 these are the codes i have and i changed the crank shaft sensor next will be cam shaft sensor idk its driving me crazy..
 

·
Registered
Joined
·
581 Posts
P2101 p0685 p2101 p0633 p2122 p2111 these are the codes i have and i changed the crank shaft sensor next will be cam shaft sensor idk its driving me crazy..
Most of those codes are throttle related. Do you have a scantool that's able to read the individual sensor values to see if they're within specs? If so, that's a good place to start.

Another possibility is that the new PCM wasn't programmed properly. You're getting an immobilizer code, which means it's likely that either your key is bad or there's a programming issue. There may also be a power or ground problem.

Did you try swapping in the original PCM to see if it will start?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
All i have is 1 of thise kenoiw how ever u spell it blue tooth that plugs in goes t o my phone were should i start checking grounds at
 

·
Registered
Joined
·
581 Posts
All i have is 1 of thise kenoiw how ever u spell it blue tooth that plugs in goes t o my phone were should i start checking grounds at
Start with the main chassis ground at the negative battery cable, then check the grounds on the back of the engine.
 
1 - 8 of 8 Posts
Top