Chrysler 300C & SRT8 Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
With the engine off I get 12.84 volts at the battery and 12.83 at the alt, when I start it I get 14.84 at the alt and the load tester on the battery says 14,83 and charging? any thoughts? also what should the starter draw be?
 

·
Registered
Joined
·
173 Posts
Charge the battery then load test it disconnected from the system.

Sent from my SM-G988U using Tapatalk
 

·
Registered
Joined
·
1 Posts
How old is your battery? I had an issue with my 2007 C. Battery checked good. But I needed a jump every time I turned off the car. So I changed the alternator thinking this was the problem. still the same issue. Call my local Chrysler dealer. he ask me how old was my battery? It was 9 years old. He said change it. I said it checks good. He told me that your system needs see a certain voltage for your Battery. So I change the battery. problem solved. wasted time and money. 5 calls to my road service, Mechanics ,10 jumps.
 

·
Registered
2006 Chrysler 300c SRT8 w/ a Hellcat Supercharger
Joined
·
98 Posts
I had issues similar on an Audi A4. If the battery has been drained a time or two it can be damaged no matter the age. However, often when starters are going out the only way they can start the car is with extra amps from the jump. Mine ended up being a starter. I jumped the car everyday for a week straight, then it quit all together.
 

·
Registered
Joined
·
16 Posts
I had issues similar on an Audi A4. If the battery has been drained a time or two it can be damaged no matter the age. However, often when starters are going out the only way they can start the car is with extra amps from the jump. Mine ended up being a starter. I jumped the car everyday for a week straight, then it quit all together.
Thats the next option...(y)
 
1 - 11 of 11 Posts
Top