Chrysler 300C & SRT8 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Ok... So I have noticed my coolant being lower than normal. I have also noticed a dry chalky residue near the upper radiator hose. The direction of the spray looks like it came from the top hose, but when I checked it...it's still tight, no cuts. Can someone look at these pics and see if you think I need to replace my upper radiator hose, or if you had seen anything like this before?



 

·
Premium Member
Joined
·
4,708 Posts
Thermostat housing gasket
There really isn't a "housing" gasket in the traditional sense, rather the gasket is silicone and nearly integral to the t-stat.

You might try just a bit of torque applied to the t-stat housing bolts to assure that they are snug.
 

·
Administrator
Joined
·
19,737 Posts
Reseal the tstat housing flange. Your hose may look fine but it expands under heat and pressure. I'd pressure test the system and look for leaks.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #5
Thanks for the advice, I'm gonna flush the system today. Get a new gasket just in case. I love this forum
 

·
Premium Member
Joined
·
4,708 Posts
Thanks for the advice, I'm gonna flush the system today. Get a new gasket just in case. I love this forum
So how did you make out?
 

·
Registered
Joined
·
181 Posts
Thanks for the advice, I'm gonna flush the system today. Get a new gasket just in case. I love this forum
You'll probably have to order the gasket. No One had it in stock when I needed one.
 

·
Registered
Joined
·
562 Posts
I have a tstat gasket if needed, I can send it out. Fel-pro makes a gasket and NAPA usually carries them in stock.
 
  • Like
Reactions: krullish

·
Registered
Joined
·
37 Posts
Discussion Starter #9
Man--- Thanks so much everybody for the comments on the thread. Turned out be that gasket, found one at my local NAPA. The last one!... Its been 2 weeks now and no new residue! I did have a bit of trouble getting in as much coolant as I took out, but over the following week or so, I just added a little more and more at a time. Runs cool, no leaks. Good enough for DIY haha. Again, thanks everybody for the help! Now onto my outer tie rods........
 
1 - 9 of 9 Posts
Top